I've installed Ubuntu alongside Windows 7. When i try to mount /mnt/sda1 which is Windows part on it, i take error such that; "The device '/dev/sda1' doesn't seem to have a valid NTFS."

NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument

The device '/dev/sda1' doesn't seem to have a valid NTFS.

Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

It is the result when i command fdisk -l;

Disk /dev/sda: 298,1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x29af3b15
Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048 546911727 546909680 260,8G  7 HPFS/NTFS/exFAT
/dev/sda2       546912254 625141759  78229506  37,3G  5 Extended
/dev/sda5  *    546912256 625141759  78229504  37,3G 83 Linux
  • Close voter(s): This problem did not ‘‘go away on its own’’. It went away when the OP used GAD3R’s answer. Oct 21, 2018 at 23:16
  • Answer was here first. But now it’s like i talked with myself. It was for GAD3R’s comment(answer).
    – Notelied
    Oct 23, 2018 at 16:32

3 Answers 3


To get the exact information about the bootable windows partition before executing ntfsfix:

sudo file -s /dev/sda1

Then use ntfsfix to fix this problem:

sudo ntfsfix /dev/sda1

Finally mount your partition.

  • 16
    I think it's a bad idea to recommend "run this utility that messes with your filesystem" without first verifying that it's actually the right partition and that it's actually NTFS that's supposed to be on there... What if it actually was a FAT filesystem (common for EFI, especially as the first partition), or ext4? It could easily leave people with an unbootable system or data loss.
    – marcelm
    Oct 21, 2018 at 18:12
  • 1
    I still get an error after running sudo ntfsfix /dev/nvme0n1p3 (it's nvme; my windows is on p3): Mounting volume... NTFS signature is missing. FAILED Attempting to correct errors... NTFS signature is missing. FAILED Failed to startup volume: Invalid argument NTFS signature is missing. Trying the alternate boot sector Unrecoverable error Volume is corrupt. You should run chkdsk. No change made
    – Samleo
    Apr 26, 2019 at 5:52

Are you sure a valid NT file system is on /dev/sda1? Does it boot?

What you see in fdisk's output is the "partition ID" and "type", given when the disk is partitioned, no file system made yet. Only after an mkfs (or "format" in windows speak) a file system is available and recognized.

  • I forgot to say, yes i can't boot windows after installing Ubuntu. After installing i could mount sda1 but now i cant. I did try Syslinux to fix Windows boot. Is there possibility to Syslinux made this partition unmountable ?
    – Notelied
    Oct 21, 2018 at 14:18
  • After using ntfsfix, the problem fixed. Thank you for helping.
    – Notelied
    Oct 21, 2018 at 14:23
  • 1
    Does 'blkid' / lsblk's FSTYPE / --fs just read the partition type too, or does it check the actual filesystem?
    – Xen2050
    Oct 21, 2018 at 14:51

I encountered this same error once, when I tried to mount a partition that I "thought" was ntfs. Attached to a CentOS host, my /etc/fstab entry worked with the type specified as ntfs.

After moving the drive to an Ubuntu host, it would not mount.

on the Ubuntu host, fdisk -l reported the partition as: HPFS/NTFS/exFAT

After changing the /etc/fstab entry on Ubuntu from ntfs to exfat, all worked fine.

Go figure...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .