1

Once after i rebooted my laptop, my sound just stopped to work since then. I've already search a lot of solutions, the common solutions didn't suit my case.

  • The auto-mute mode is disabled in alsamixer.
  • The driver is currently loaded.
  • There aren't any mute button selected in pavucontrol, and I've already tried to change between all profile available there.
  • I've already removed the files of .config/pulse/ and started the service again.
  • When any sound application is running as spotify or firefox, in pavucontrol the visualizer bar of the application reacts, bouncing up and down.

The only thing strange that I have noticed, it was the pulseaudio -vvvv --log-time=1 output raising pa_pid_file_create() failed. However the pulseaudio seems to be working fine.

(   0.000|   0.000) I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
(   0.000|   0.000) I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
(   0.000|   0.000) D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
(   0.005|   0.005) D: [pulseaudio] core-util.c: RealtimeKit worked.
(   0.005|   0.000) I: [pulseaudio] core-util.c: Successfully gained nice level -11.
(   0.005|   0.000) I: [pulseaudio] main.c: This is PulseAudio 10.0
(   0.005|   0.000) D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
(   0.005|   0.000) D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fdebug-prefix-map=/build/pulseaudio-ZMrhzG/pulseaudio-10.0=. -fstack-protector-strong -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
(   0.005|   0.000) D: [pulseaudio] main.c: Running on host: Linux x86_64 4.9.0-7-amd64 #1 SMP Debian 4.9.110-3+deb9u1 (2018-08-03)
(   0.005|   0.000) D: [pulseaudio] main.c: Found 4 CPUs.
(   0.005|   0.000) I: [pulseaudio] main.c: Page size is 4096 bytes
(   0.005|   0.000) D: [pulseaudio] main.c: Compiled with Valgrind support: no
(   0.005|   0.000) D: [pulseaudio] main.c: Running in valgrind mode: no
(   0.005|   0.000) D: [pulseaudio] main.c: Running in VM: no
(   0.005|   0.000) D: [pulseaudio] main.c: Optimized build: yes
(   0.005|   0.000) D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
(   0.005|   0.000) I: [pulseaudio] main.c: Machine ID is c32fd4b4661649caa3522bccc1cb42f0.
(   0.005|   0.000) I: [pulseaudio] main.c: Session ID is 1.
(   0.005|   0.000) I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
(   0.005|   0.000) I: [pulseaudio] main.c: Using state directory /home/rafa/.config/pulse.
(   0.005|   0.000) I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-10.0/modules.
(   0.005|   0.000) I: [pulseaudio] main.c: Running in system mode: no
(   0.005|   0.000) E: [pulseaudio] pid.c: Daemon already running.
(   0.005|   0.000) E: [pulseaudio] main.c: pa_pid_file_create() failed.

My configurations:

pactl info output:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 16
Tile Size: 65472
User Name: rafa
Host Name: rafa
Server Name: pulseaudio
Server Version: 10.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
Cookie: 6573:78a6

lspci -vvv output:

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    Subsystem: Dell Sunrise Point-LP HD Audio
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 32
    Interrupt: pin A routed to IRQ 280
    Region 0: Memory at d5320000 (64-bit, non-prefetchable) [size=16K]
    Region 4: Memory at d5300000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl

dmesg | grep 00:1f.3 output:

[    0.228974] pci 0000:00:1f.3: [8086:9d70] type 00 class 0x040300
[    0.228995] pci 0000:00:1f.3: reg 0x10: [mem 0xd5320000-0xd5323fff 64bit]
[    0.229020] pci 0000:00:1f.3: reg 0x20: [mem 0xd5300000-0xd530ffff 64bit]
[    0.229067] pci 0000:00:1f.3: PME# supported from D3hot D3cold
[    0.229203] pci 0000:00:1f.3: System wakeup disabled by ACPI
[    2.766555] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    3.845342] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.984520] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
[    5.985440] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
[    5.985500] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20

cat /proc/asound/cards output:

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd5320000 irq 280

aplay -l output:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3234 Analog [ALC3234 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

uname -a output:

Linux rafa 4.9.0-7-amd64 #1 SMP Debian 4.9.110-3+deb9u1 (2018-08-03) x86_64 GNU/Linux

OS: Debian-9.5
i3 --version:4.13

UPDATE:
After all, I decided to use the brute force and I removed all packages from alsa and pulseaudio, and I installed it again. After a reboot, It is working back again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.