4

I am trying to connect my Android phone to the KDE Connect app with my laptop.

My system is a Minimal Debian Sid system with just i3wm no other alternate Desktop Environments or Window managers installed.

When I initiate a pair request from my phone to the computer I get a notification as seen in the following screenshot.

enter image description here

When I click on the notification nothing happens. On desktop environments such as Gnome or KDE, the notification also has an accept or reject button, which is not the case with the default notification handler of i3wm.

So how do I get my laptop get paired with KDE Connect now? Any alternate notification handlers which would do the job here?

I similar situation occurred to me a few months ago when I was trying to pair a bluetooth speaker to my laptop, which required me to enter a pairing key code which was not possible through a notification setup like this.

Details of my setup: Debian GNU/Linux Unstable(sid) WM: i3

After following the instructions by cocoa1231 I tried launching the daemon from /usr/lib/

rajudev@sanganak:/usr/lib/x86_64-linux-gnu/libexec$ ./kdeconnectd 
kdeconnect.core: KdeConnect daemon starting
kdeconnect.core: onStart
kdeconnect.core: KdeConnect daemon started
kdeconnect.core: Broadcasting identity packet
kdeconnect.core: TCP connection done (i'm the existing device)
kdeconnect.core: Starting server ssl (I'm the client TCP socket)
kdeconnect.core: TCP connection done (i'm the existing device)
kdeconnect.core: Starting server ssl (I'm the client TCP socket)
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a new device "xiaomi"
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a known device "xiaomi"
kdeconnect.core: TCP connection done (i'm the existing device)
kdeconnect.core: Starting server ssl (I'm the client TCP socket)
kdeconnect.core: TCP connection done (i'm the existing device)
kdeconnect.core: Starting server ssl (I'm the client TCP socket)
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a known device "xiaomi"
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a known device "xiaomi"
kdeconnect.core: creating pairing handler for "22d1625020250fbf"
kdeconnect.core: Pair request
kdeconnect.core: Sending onNetworkChange to  1  LinkProviders
kdeconnect.core: Broadcasting identity packet
kdeconnect.core: Starting client ssl (but I'm the server TCP socket)
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a known device "xiaomi"
Device pairing error "Timed out"
kdeconnect.core: TCP connection done (i'm the existing device)
kdeconnect.core: Starting server ssl (I'm the client TCP socket)
kdeconnect.core: TCP connection done (i'm the existing device)
kdeconnect.core: Starting server ssl (I'm the client TCP socket)
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a known device "xiaomi"
kdeconnect.core: Socket successfully established an SSL connection
kdeconnect.core: It is a known device "xiaomi"

2 Answers 2

7

You're going to want to run /usr/lib/kdeconnectd and add that in your i3config

exec --no-startup-id /usr/lib/kdeconnectd

so that it works every time. And launch the settings through the indicator. Weirdly it doesn't launch directly. Gotta launch the indicator and from there launch the settings (during pairing process)

For the pairing process, dunst doesn't support interactive notifications, so open up the KDE Connect Indicator and launch the settings from the indicator and when you try to pair you can accept from the configure dialog. Here

4
  • 1
    I tried following your instructions. In my case the location was /usr/lib/x86_64-linux-gnu/libexec/kdeconnectd . Although this did not solve my issue. This seems a step to start kdeconnect daemon. In my case the daemon was already running.
    – rajudev
    Oct 20, 2018 at 13:30
  • Oh okay. Well dunst doesn't support interactive notifications, so open up the KDE Connect Indicator and launch the settings from the indicator and when you try to pair you can accept from the configure dialog. Here
    – user316808
    Oct 20, 2018 at 13:39
  • If you will add this comment briefly as an answer I'll accept that as an answer. This precisely helped me solve the issue. Or else I'll have to write an answer for my own question
    – rajudev
    Oct 20, 2018 at 13:54
  • Cool, appended to the answer
    – user316808
    Oct 20, 2018 at 14:01
0

Dunst currently supports actions in notifications: https://wiki.archlinux.org/title/Dunst#Actions

1
  • Welcome to the site, and thank you for your contribution. Please note that your post relies heavily on external content, so you may want to summarize the most important points here. Link-only answers are discouraged, as the link may become invalid or the linked content change.
    – AdminBee
    May 27, 2021 at 7:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .