1

I run a ps command inside a startup script, if I put in:

ps -A -o euser,pid...

I get this output:

EUSER      PID CMD                         %CPU   RSS    SZ     ELAPSED 
root       644 ./code                       0.0   996  2963       00:00

It's there each time.

If I run:

ps -C ./code -o euser....

it does not display anything at all.

Any suggestions?

  • Did you literally type “ps -A -o euser,pid...” and “ps -C ./code -o euser....”? I don't know of any system that accepts ... or .... here: what operating system are you using? If you actually typed something else and not the dots: copy-paste what you typed, exactly. It may be relevant. And do tell us which unix variant you're running. – Gilles 'SO- stop being evil' Sep 9 '12 at 21:40
0

Try the ps -C with just the bare script name (i.e. without ./). e.g.

ps -C code -o euser....

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.