0

I am using UP Board. IT has Ubilinux installed in it. I have made a browser kiosk so that it automatically logs in to the browser full screen mode but I am having an issue on reboot. Whenever I try to reboot I have to enter a password on Login screen. I want it to be removed so that it can auto logged in without any input from user.The boot up page

The OS selection screen. Maybe version would help you?

Login Page. This is the page I want to remove. I have several options as you can see on top left corner 8n Session. I want to use LXDE as my current session.

  • can you tell us which display manager ubilinux uses? Autologin usually has to do with /etc/<name of display manager>.conf file – Ankur S Oct 19 '18 at 11:13
  • if it is gdm, take a look at help.gnome.org/admin/system-admin-guide/stable/… – Ankur S Oct 19 '18 at 11:16
  • I think its LXDE. How do i know which display manager I am using? – Usman Khan Oct 19 '18 at 11:42
  • see since ubilinux is based on debian , do cat /etc/X11/default-display-manager. Most probably and by the looks of it your display manager is lxdm. For that autologin procedure is explained here – Ankur S Oct 19 '18 at 12:53
0

Since your Display Manager seems to be lxdm, you should follow the following procedure. You have to edit the Display manager Config options for autologin. The file is /etc/lxdm/lxdm.conf.

  1. sudo nano /etc/lxdm/lxdm.conf

  2. Find the line #autologin=something

  3. Replace it with autologin=UP or whatever your username happens to be.

  4. Reboot

For more info see here

|improve this answer|||||
0

I created a file named sddm.conf in /etc/ directory. I placed this in it. Now I can login without any password. [Autologin] User=up Session=LXDE

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.