1

I have installed lynx using brew on macOS. It runs decently after me enabling all cookies http://www.pc-freak.net/blog/how-to-permanently-enable-cookies-in-lynx-text-browser-disable-accept-cookies-prompt-in-lynx-console-browser/

Is there a way to get it to feasible to automatically say yes to "Accept invalid cookie path=/complete/search as a prefix of '/'?"

It asks me on most web pages I visit. Under the options page it is called "Invalid-cookie prompting."

2 Answers 2

1

invoking lynx as

lynx -cookies -accept_all_cookies

seems to do the trick; I have seem some suggestions elsewhere to alias lynx= same...

0

You'd have to configure it to ignore the problem with specific domains: COOKIE_ACCEPT_DOMAINS.

In a followup comment, mention was made of

Invalid-Cookie Prompting

That is normally not saved to the ~/.lynxrc, as indicated by the (!) after the name. You can configure lynx to save (and read) the value by adding

ENABLE_LYNXRC:FORCE_COOKIE_PROMPT:ON

to the lynx.cfg file.

6
  • Isn't that a comma separated list of domains instead of a universal accept
    – William
    Oct 18, 2018 at 23:40
  • yes - I said "specific". Oct 18, 2018 at 23:44
  • There is an option for this under the options page that works but I don't know where the option is stored
    – William
    Oct 18, 2018 at 23:48
  • I tried this option also it doesn't work
    – William
    Oct 18, 2018 at 23:57
  • That actually suppresses prompts for more than the issue you mentioned. But "doesn't work" can cover a lot more territory. Oct 18, 2018 at 23:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .