1

I can't boot my pc because the Xserver doesn't start. What's weird is that when I use SDDM it boots just fine. I also tried to use Lightdm a few months ago but it didn't want to boot, I'm guessing because of this problem.

I've had this problem for like a year but it never really bothered me because I always used SDDM. I'd like to stop using it so that's why I need this fixed.

System Info

Neofetch:

OS: Arch Linux x86_64 
Host: 80WK Lenovo Y520-15IKBN 
Kernel: 4.18.14-arch1-1-ARCH 
Uptime: 10 mins 
Packages: 1554 (pacman) 
Shell: zsh 5.6.2 
Resolution: 1920x1080, 1920x1080 
DE: KDE 
WM: KWin 
WM Theme: Breezemite 
Theme: Breeze [KDE], Adwaita [GTK2], X-Arc-Plus [GTK3] 
Icons: Papirus-Light [KDE], Adwaita [GTK2], Papirus [GTK3] 
Terminal: konsole 
Terminal Font: DejaVu Sans Mono 10 
CPU: Intel i7-7700HQ (8) @ 3.800GHz 
GPU: Intel Device 591b 
Memory: 1758MiB / 7851MiB

I'm using the proprietary Nvidia driver. Not bumblebee or nouveau because of their performance hit.

uname -a : Linux ArchLinux 4.18.14-arch1-1-ARCH #1 SMP PREEMPT Sat Oct 13 13:42:37 UTC 2018 x86_64 GNU/Linux

pacman -Q nvidia : nvidia 410.57-6

I enabled KMS to eliminate screen tearing, but disabling it doesn't help. I don't have an xorg.conf file because when I do, even SDDM won't start. nvidia-xconfig has never worked for me.

Logs:

/var/log/Xorg.0.log:

These are both executed with SDDM disabled, so I just log in to the first tty:

when executing startx: https://hastebin.com/zadepawiwo

when executing xinit : https://hastebin.com/muredinume

With SDDM enabled, so a normal boot: https://hastebin.com/anatocavur

(is hastebin the right place or should I upload them elsewhere?)


EDIT: this is what I see in the terminal when I execute:

sudo startx: sudo startx (That d-bus thing might be interesting but I have no idea what it means).

startx: startx

Here's my .xinitrc:

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

xsetroot -cursor_name left_ptr
xrandr --output eDP-1 --primary
xrandr --output HDMI-1 --above eDP-1
xrandr --dpi 96


# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"
fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs


if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

sxhkd &
statnot &
feh --bg-fill ~/Pictures/DnA7hZgU8AAxfxC.jpg:large.jpg
exec bspwm

As for the 'possible duplicate' from here, I tried their solutions and they didn't work. For me, SDDM can start when I have it enabled, but I want to use bspwm without a DM.


Disabling the NVIDIA GPU in my BIOS settings made startx work, so that reveals that the problem is with NVIDIA. Are my drivers the problem? Is it something else?

  • A downvote? What did I do wrong? – zjeffer Oct 18 '18 at 21:25
  • Have startx or xinit ever worked for you? What is in your .xinitrc ? – JigglyNaga Oct 19 '18 at 16:27
  • 1
    The downvote might have been for using pastebin (or similar) -- it's better to include all the relevant text in the question: Policy on pastebins for additional info?. Same for links to external image hosts -- images can be included in the question, but should only be used when their content can't be represented in text. – JigglyNaga Oct 19 '18 at 16:28
  • The "dbus thing" suggests you have no .xinitrc, so the default one, /etc/X11/xinitrc, is being used instead. Is xterm installed? – JigglyNaga Oct 19 '18 at 16:58
  • Thanks for the help so far. I don't think they ever worked, but I've always used SDDM so I have no clue. I edited my .xinitrc in the post. As for the pastebins, I can't really post the whole logs here because they are too big. Why would it not find my .xinitrc? Does it need special permissions? xterm is installed. – zjeffer Oct 19 '18 at 17:05
2

Added

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

to my ~/.xinitrc file and that made me able to boot with my NVIDIA GPU enabled in BIOS, and without SDDM.

The reason why that wasn't added yet was because when using SDDM I had to add that to /usr/share/sddm/scripts/Xsetup instead of to ~/.xinitrc. I completely forgot that I didn't add it my ~/.xinitrc file like it says here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.