0

We have linux machines with RedHat 6.5 operating system.

When we try to telnet to localhost on port 8182, we get connection refused:

service iptables status
Firewall is not running

telnet localhost  8182
Connection refused

cat /etc/selinux/config
SELINUX=DISABLED
SELINUXTYPE=targeted 

Any suggestion on how to find the reason that we get connection refused even if the firewall is down and selinux is disabled

  • There is no service listening on port 8182. – n8te Oct 18 '18 at 6:25
  • how to verify which service should listening to port 8182 – yael Oct 18 '18 at 6:28
  • 1
    Can I ask what is giving you the idea that something should be listening on that port? Why did you pick that port in particular? – n8te Oct 18 '18 at 6:28
  • on other machine , port 8182 is listening , but on other same machine its not listening – yael Oct 18 '18 at 6:29
  • Apparently port 8182 is used for vmware fault domain manager. Do you have vmware installed on the other PC? – n8te Oct 18 '18 at 6:31
1

when we do telnet to localhost on port 8182 , we get connection refuse

This means that there's nothing running on port 8182 on the machine. Check that the service supposed to run on that port is installed and running. (TCP/UDP 8182 is usually used for the VMware Fault Domain Manager.)

On a side note, you do not need to open ports on the firewall or disable it for connections from localhost to localhost.

| improve this answer | |
0

If you are getting connection refused there is either no service listening on port 8182 on your loopback ip address, or there is a firewall in the way.

You can verify what processes are listing on which ip/ports using netstat:

netstat -tunlp

Where t is tcp, u is udp, n is show ip and port numbers rather than names, l is listening and p is show the process.

You can verify if there is a firewall in the way by using iptables:

iptables -nvL
| improve this answer | |
  • OP already verified that the firewall is disabled, and firewalls don't block local connections anyway. – dr_ Oct 18 '18 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.