0

We have some old binaries which ran on Sun SPARC systems from around 2000, and we'd like to run them again (we do not have the source code.) I tried running the binaries on a Sun Blade 1500 with a SPARC processor and Solaris 10, but I get errors like

ld.so.1: plot: fatal: libF77.so.3: open failed: No such file or directory

I added a new drive with more space, installed Solaris 10, Java 8 JRE, and Oracle Developer Studio 12.6 with the hope of getting the libraries needed. Alas, I get the same result. It looks like libF77.so.3 used to be part of Sun Studio 12. Any idea where to find it now?

  • let me know if the solution below works for you if not we can find alternative – user88036 Oct 18 '18 at 0:00
  • Try oracle.com/technetwork/indexes/downloads/… . I can't verify the links work; they require a support contract, which I don't have. – Mark Plotnick Oct 18 '18 at 0:03
  • Thanks Mark-- alas, I was unable to find an older version which contained this library. – lava37 Oct 22 '18 at 15:51
1

If you have libF77.so.3, you should find it under this path /opt/SUNWspro/lib/. Also, check if you have it and if the directory is in your $LD_LIBRARY_PATH. libF77.so is only distributed with the Sun F77 compiler, so binaries should be linked mit static Fortran libraries.

Basically, you need Fortran 77 legacy libraries, which comprised of:

libF77.so.2
libF77.so.3
libF77.so.4
libF77_mt.so.2
libF77_mt.so.3
libF77_mt.so.4
libFposix.so.1
libFposix_c.so.1
libM77.so.2
libV77.so.2
libV77.so.3

You can download here

  • Thanks Goro-- how would you recommend installing this file? I tried creating a symbolic link at /lib/libF77so.3 to it but got "ld.so.1: plot: fatal: /lib/libF77.so.3: wrong ELF data format: ELFDATA2LSB". – lava37 Oct 18 '18 at 16:45
  • Dear @lava37 this file is executable, it should work once you click on it and it will install C++ compiler Fortran 77 compiler and the library libF77.so.3, did you install it? the message you got means either libF77.so.3 is corrupted or not exist? – user88036 Oct 18 '18 at 18:53
  • Attempting to execute open-watcom-f77-linux-1.9 results in "bash: /Desktop/open-watcom-f77-linux-1.9: Invalid argument". I redownloaded the file and made it excutable both times, and tried adding --help or -help but got the same results. – lava37 Oct 19 '18 at 14:06
  • Linux/x86 binaries won't run on Solaris/SPARC – alanc Oct 21 '18 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.