0

Note: This question was originally asked on Arduino Stack exchange, but closed as off-topic because it's an OpenWRT issue.

I have a Geeetech Iduino Yun Shield. I accidentally flashed the wrong firmware image (not the sysupgrade) to the board. I then tried using the Yun UBoot Reflash method. However, when I open the console monitor from the IDE and restart/reboot the board, I do not get the UBoot prompt. I have attempted to run it at least ten times without receiving any console/serial output.

The shield is running on a Leonardo base board.

Is there anything I can do to load the correct firmware onto the shield and get it operational or is it truly bricked? If it's bricked, is it possible to obtain a new Atheros AR9331 module to replace the existing one or should I buy a new Yun?

I have tried to get the shield to do an FTP boot, as detailed here by Majenko. I get to the stage where I get the dr_boot> prompt. However, when I type in tftpboot 0x81000000 dragino2-yun-common-v2.0.6-kernel.bin, I get no feedback; it just sits there indefinitely (unless I interrupt the process). I can't figure out what I'm doing wrong.

Note: This question, currently unanswered may be related; I'm not sure.

2
  • It seems more a related hw than Unix problem. The board may be toast. Oct 17, 2018 at 12:46
  • Is there anything I can do to diagnose if the board (or which part thereof) is toast? Should I ask in EE? Oct 20, 2018 at 13:08

0

You must log in to answer this question.

Browse other questions tagged .