0

I have a xubuntu 18.04 on a Lenovo Thinkpad R60 and the volume hotkeys are not working at all. xev gives no feedback either so the buttons seem no to be recognized by the system. How can I make them work?

0

Enable The Hotkeys

Maybe the buttons are not enabled by the thinkpad_acpi. You can enable all hotkeys by

echo enable,0xffffffff >/proc/acpi/ibm/hotkey

Since you have to be root a simple sudo will not suffice because it only effects the echo. So you have either to become root by sudo -i or encapsulate by e.g.

sudo bash -c echo enable,0xffffffff > /proc/acpi/ibm/hotkey

or

echo enable,0xffffffff | sudo tee /proc/acpi/ibm/hotkey

Since it is a bitmask you are working with you can enable and disable hotkeys separately. Refer to module documentation for more info.


Make the change permanent

To survive the next reboot you may add the command to your /etc/rc.local

If you are using Ubuntu 18.04 or above the file may be missing since systemd is handling this. But if existing the file will be used as you can convice yourself by looking into sudo systemctl edit --full rc-local.

The file has to be executable and needs a shebang.

#!/bin/sh

echo enable,0xffffffff > /proc/acpi/ibm/hotkey

echo 0

If you created the file make it executable by

chmod +x /etc/rc.local

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.