I have Debian 6.0. In my interfaces file (/etc/network/interfaces) I have the following lines:

auto eth0
iface eth0 inet static

Every time I start the computer, eth0 is not working.

When I enter ifconfig -a, eth0 is not "up" and "running".

I have to enter:

 ifconfig eth0 up
 /etc/init.d/networking restart

... and then it works.

How do I have to change the config in order to have a working eth0 in the beginning?

  • i guess it's related to your driver card.before ifconfig eth0 up use dmesg and see up it's alias names? – PersianGulf Sep 8 '12 at 22:03
  • What is the networking service status before restart? – olivecoder Sep 9 '12 at 2:03
  • 1
    Is there anything about eth0 in the system logs (/var/log/*)? If you run /etc/init.d/networking start while eth0 is down, do you get any error message? Is there another network interface (besides lo)? – Gilles 'SO- stop being evil' Sep 9 '12 at 20:04
  • 2
    please put all of /etc/network/interfaces – PersianGulf Sep 9 '12 at 22:24
  • Please show the output of ifup -v eth0 after startup ? – BatchyX Mar 13 '13 at 8:35

How do I have to change the config in order to have a working "eth0" in the beginning?

Whenever I hear "in the beginning" it reminds of rc.local.

This is not really a direct answer for solving your problem but it seems that you're experiencing some difficulties with the driver.

For a quick fix, why not using rc.local? if your problem gets solved by typing those 2 commands every time you boot into your box then add them at the end of /etc/rc.local.

For an in-depth fix for your problem, first and before everything else do a:

apt-get update && apt-get upgrade

I had the same issue in my Backtrack, it solved after update. Apparently the same topic discussed here: Debian not starting eth0 at boot

  • Shouldn't that be apt-get update && apt-get upgrade or better apt-get update && apt-get dist-upgrade (for most practical purposes)? – 0xC0000022L Feb 10 '13 at 22:02
  • The referenced linkis broken... – Mendes Dec 15 '18 at 21:19

add following line to /etc/network/interfaces :

allow-hotplug eth0

Source:man interfaces

lines beginning with "allow-" are used to identify interfaces that should be brought up automatically by various subsytems. This may be done using a command such as "ifup --allow=hotplug eth0 eth1", which will only bring up eth0 or eth1 if it is listed in an "allow-hotplug" line. Note that "allow-auto" and "auto" are synonyms.


Please check that it is not disabled in the networking-scripts configs. Do this:

sudo vi /etc/sysconfig/network-scripts/ifcfg-eth0

See if ONBOOT="yes". If it says "no" then it is disabled at startup.

Here's my ifcfg-eth0 file as a reference:


then do:

sudo service network restart

Ip address is not static set and won't change after reboot.

  • 4
    Debian does not use sysconfig or redhat's configuration scripts. – BatchyX Mar 13 '13 at 8:23
  • 2
    it's for RHEL/CentOS/Fedora not for Debian based system's – Rahul Patil Apr 12 '13 at 4:26

Is network service is enable at startup ?

Try using sysv-rc-conf Or rcconf tools

Or do it manually using :

sudo update-rc.d network defaults
  • update-rc.d: command not found – Max Jul 5 '17 at 9:27
  • update-rc.d: error: initscript does not exist: /etc/init.d/network Debian 6 – Mendes Dec 15 '18 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.