2

I'm on FreeBSD. I used from a cisco router as the server and my system as the client. I used ntp to sync the clock between server and client. It worked and the clock has synced but when I run ntpq -p, it shows the correct value after about 5 minute.

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
  12.12.12.1      LOCAL(1)         8 u   33   64  377    0.649   10.050  26.488

after 5 min the 12.12.12.1 changed to *12.12.12.1.

How can I reduce this time that the ntpq -p shows the changes immediatly?

2
  • I'm not sure I understand what the issue is. What do you mean by "the correct value"? And what "changes" do you want to see?
    – Kusalananda
    Oct 16, 2018 at 9:23
  • @Kusalananda I edited my post.
    – F.M
    Oct 16, 2018 at 10:45

1 Answer 1

3

It is possible that ntpq is trying to resolve DNS for the name of the NTP peers and that a misconfigured DNS is causing the timeout and delay of 5 minutes.

You can confirm that that's the case by asking it not to resolve DNS, using the ntpq -np command (the -n flag tells it not to resolve DNS.)

If that's indeed the case, you can then look into why resolving DNS for those IPs is not working (but that's a separate topic, probably deserves a specific question.)

4
  • thanks for your reply. I tested ntpq -np but it doesn't work.
    – F.M
    Oct 16, 2018 at 5:30
  • @F.M Please specify what "does not work" actually mean.
    – Kusalananda
    Oct 16, 2018 at 9:22
  • To rephrase Filipe Brandenburger's answer: if you have DNS problems and have configured NTP time sources in /etc/ntp.conf by names, it might take 5 minutes for ntpd to fully start up. But once it has completed startup, you can diagnose it by comparing how much time is taken by ntpq -p vs. ntpq -np. If ntpq -p is slow but ntpq -np responds immediately, you'll need to either fix your DNS resolution or replace all time source names in /etc/ntp.conf by the respective IP addresses as a work-around. If both ntpq -p and ntpq -np are slow, the problem is elsewhere.
    – telcoM
    Oct 16, 2018 at 9:47
  • @telcoM They're both slow.
    – F.M
    Oct 16, 2018 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.