1

I have a problem with connecting external monitor to my Dell Precision M6500 laptop. I'm running Debian Stretch with gdm3.

I try to connect external monitor by VGA. My laptop has DP and VGA port.

When using lspci the VGA controller is found:

michal@ntpc01:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G92GLM [Quadro FX 2800M] (rev a2)

But using xrandr, there is no other port visible:

michal@ntpc01:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1440 x 900, maximum 1440 x 900
default connected primary 1440x900+0+0 0mm x 0mm
   1440x900       0.00* 
   1280x800       0.00  
   1280x720       0.00  
   1024x768       0.00  
   800x600        0.00  
   640x480        0.00  

I installed nvidia drivers in legacy(340xx) version and bumblebee. As instructed in NvidiaDirvers Manual. I have also installed firmware-linux-nonfree. Before installing drivers I have no problem with listing displays in xrandr, but monitor hasn't been recognized. I found that it may be caused by not having drivers, so I installed it and have a problem like this.

Xorg logs(In log there are two files with same modification date so I paste both):
Xorg.0.log
Xorg.1.log

0

The logs indicate you're falling back to the unaccelerated vesa Xorg driver module.

[    25.387] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    25.387] (II) FBDEV: driver for framebuffer: fbdev
[    25.387] (II) VESA: driver for VESA chipsets: vesa
[    25.519] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[    25.519] (EE) open /dev/dri/card0: No such file or directory
[    25.519] (WW) Falling back to old probe method for modesetting

The proprietary driver is not being used at all.

The vesa driver has no clue about multiple displays, so that is definitely the cause of your problem.

First, you should ensure that the appropriate kernel modules are loaded and working. If you want to use the open-source nouveau driver, that would be the nouveau kernel module. If it does not get loaded, find out why and fix it.

If you want to use the proprietary nvidia driver instead, then the nvidia_drm module should be loaded.

Either of those solutions would work with your card, but you must pick one or the other, and make sure the opposite driver's kernel module is blacklisted in /etc/modprobe.d/*.conf so the system won't attempt to load it: the modules of different drivers conflict with each other.

In both cases, when the appropriate modules are loaded and working, the /dev/dri/card0 device should then exist. At that point, the X server should automatically select the appropriate driver, and xrandr should then see the full functionality available in your display controller.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.