0

I currently have Linux Mint 18.3 Cinnamon 64-bit installed. When I search for an app with apt (apt show [package name]) it often happens that the version available is outdated, even though apt says it's getting its packages from Ubuntu repos, which I know to be up to date from https://packages.ubuntu.com/. For example apt show terminator shows me Version: 0.98-1 whereas Ubuntu site shows 1.91-1. This has happened on a number of different packages, so how can I force apt to install the latest version?

  • Have you tried apt-get upgrade && apt-get update ? Your packages also can be outdated due some dependencies. – mrc02_kr Oct 15 '18 at 11:03
  • Yes, I already tried that and all dependencies seem to be up to date, but no luck. – Marco Venuti Oct 15 '18 at 11:13
1

Linux Mint 18.x releases are based on Ubuntu 16.04 LTS, so you only get the versions of packages which are made available in 16.04 (plus whatever packages are added or upgraded in Mint itself).

Thus for Terminator, you get 0.98-1 — see the Xenial Xerus entries — and not 1.91-1, which is only available in Ubuntu 18.04 and 18.10. If you want newer packages you should upgrade to Linux Mint 19, which is based on Ubuntu 18.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.