I have a Raid 0 setup (striping) via BIOS not through software raid. When I install linux mint or Ubuntu it fails to install the boot loader or set the boot loader to boot. I get an error stating grub-install /dev/sda failed. On start up of a fresh install I get the blinking cursor and no grub boot menu.

I've tried a few different fixes with gpart and trying to use the advanced partition during install but I keep getting bootloader failed to load.

I've also used the fdisk -l outputting only /dev/sda1 info which is the usb liveCD. Howevever, using fdisk /dev/mapper/nvidia_djcffehh -l will show the RAID drive with the boot partition, swap, and file system.

Not sure why it isn't working as it has worked in the past but since doing a fresh install it doesn't work properly.

Is it possible that because the liveCD USB is being mounted at /dev/sda that it is messing with the file system? Also I am using Linux Live USB creator. The USB driver appears as a hard drive on the bios and not as a removable device.

Any ideas would be helpful.

  • RAID 0 is striping, RAID 0 is mirroring: which one is it? BIOS RAID (“fakeraid”) is usually a bad idea (among others, because of incompatibilities of this sort). Commented Sep 8, 2012 at 13:12
  • Yup I mixed it up I meant RAID 0. I'm just puzzled because the "fakeraid" worked with it before and had no problems. I think you meant RAID 1 is mirroring.
    – Grant
    Commented Sep 8, 2012 at 21:09
  • Does your BIOS RAID 0 present a single device to the OS? When you boot the Mint or Ubuntu DVD, open a shell terminal and type the command "cat /proc/partitions". There should be one big device representing what the hardware RAID put together via your (sata?) controller. Can you see that?
    – Skaperen
    Commented Sep 9, 2012 at 2:12

1 Answer 1


RAID1 is mirroring, not striping. Furthermore, using BIOS fakeraid is not recommended - Linux software RAID (mdraid) will be more reliable, and will help you to avoid issues like this.

If you are absolutely sure you want to installing GRUB on fakeraid, you must follow a quite complicated procedure, that is described here: https://wiki.archlinux.org/index.php/Installing_with_Fake_RAID#Install_GRUB

  • Opps I mixed up RAID 0 and 1 but, I am doing RAID 0 striping. Looks like I will use mdraid instead. Thanks!
    – Grant
    Commented Sep 8, 2012 at 21:11
  • If you are doing software RAID, I generally recommend a separate non-RAID device for the OS. A smaller (64GB) SSD device would be great (don't put swap on SSD).
    – Skaperen
    Commented Sep 9, 2012 at 2:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .