1

I am using a wacom bamboo graphics tablet in a dual monitor setup on Linux Mint 19 Cinnamon. My combined screen has a significantly different aspect ratio then the graphics tablet. When I draw a perfect circle on the graphics tablet the mouse on the screen draws an ellipse.

How can I map my graphics tablet to both screens preserving a correct aspect ratio?

For a correct aspect ratio a part of the tablet has to be dead. The following illustration shows my current mapping on the left, and my desired mapping on the right.

current and desired mapping

In the cinnamon system preferences, there is a »keep aspect ratio« setting that only works for single monitors. I can enable »keep aspect ratio« as long as »map to single monitor« is enabled. When I disable »map to single monitor« then »keep aspect ratio« automatically turns off too.

non-working setting

2

When googling you often find solutions of the form

  • Use xsetwacom list devices and xsetwacom get INSERT_NUMBER Area to get the active area of your graphics tablet.
  • (Manually) calculate the biggest area with the same aspect ratio as your display.
  • Use xsetwacom set INSERT_NUMBER Area 0 0 INSERT_WIDTH INSERT_HEIGHT to set your active graphics tablet area.
  • Write a startup script to make the changes permanent.

However, there is a very simple alternative solution. Apparently, the setting »keep aspect ratio« mentioned by you also works for dual monitor setups, only enabling it is forbidden by the system settings dialog. Nevertheless, you can enable it with dconf. Open a terminal and enter

dconf list /org/cinnamon/settings-daemon/peripherals/wacom/

this should print something like

ef635a010d284bc38d762d2b9f0e65ac-usb:056a:00dd/

Copy paste ✱ that string into the following command

dconf write /org/cinnamon/settings-daemon/peripherals/wacom/PASTE_HERE/keep-aspect true

Changes should take effect immediately. For me this works as expected. I have used this trick for months and have not experienced any problems so far. When you go into your system settings, you see that »keep aspect ratio« is enabled despite being greyed out.

»keep aspect ratio« greyed out but enabled

✱ Instead of copy-pasting, you can also use the following bash command (no guarantees in case of missing/multiple graphics tablets):

p=/org/cinnamon/settings-daemon/peripherals/wacom/;
dconf write "$p$(dconf list $p)keep-aspect" true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.