0

I'm trying to connect to a WiFi with WPA-EAP, but it always fails with error:

failure to add network: invalid message format

Full log from journalctl:

NetworkManager[668]: <info>  device (wlp5s0): Activation: starting connection 'eduroam' (1ed02f15-9f55-452c-9b1c-4b2670bb2eac)
NetworkManager[668]: <info>  audit: op="connection-activate" uuid="1ed02f15-9f55-452c-9b1c-4b2670bb2eac" name="eduroam" pid=3216 uid=1000 result="success"
NetworkManager[668]: <info>  device (wlp5s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[668]: <info>  manager: NetworkManager state is now CONNECTING
NetworkManager[668]: <info>  device (wlp5s0): set-hw-addr: reset MAC address to 80:86:F2:1D:79:41 (preserve)
NetworkManager[668]: <info>  device (wlp5s0): state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[668]: <info>  device (wlp5s0): Activation: (wifi) access point 'eduroam' has security, but secrets are required.
NetworkManager[668]: <info>  device (wlp5s0): state change: config -> need-auth (reason 'none') [50 60 0]
kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
NetworkManager[668]: <info>  device (wlp5s0): state change: need-auth -> prepare (reason 'none') [60 40 0]
NetworkManager[668]: <info>  device (wlp5s0): state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[668]: <info>  device (wlp5s0): Activation: (wifi) connection 'eduroam' has security, and secrets exist.  No new secrets needed.
NetworkManager[668]: <info>  Config: added 'ssid' value 'eduroam'
NetworkManager[668]: <info>  Config: added 'scan_ssid' value '1'
NetworkManager[668]: <info>  Config: added 'key_mgmt' value 'WPA-EAP'
NetworkManager[668]: <info>  Config: added 'proto' value 'RSN'
NetworkManager[668]: <info>  Config: added 'pairwise' value 'CCMP'
NetworkManager[668]: <info>  Config: added 'group' value 'CCMP TKIP'
NetworkManager[668]: <info>  Config: added 'password' value '<hidden>'
NetworkManager[668]: <info>  Config: added 'eap' value 'PEAP'
NetworkManager[668]: <info>  Config: added 'fragment_size' value '1266'
NetworkManager[668]: <info>  Config: added 'phase2' value 'auth=MSCHAPV2'
NetworkManager[668]: <info>  Config: added 'ca_cert' value '<mypath>/ca.pem'
NetworkManager[668]: <info>  Config: added 'altsubject_match' value 'DNS:<mydomain.com>'
NetworkManager[668]: <info>  Config: added 'identity' value '<myusername>'
NetworkManager[668]: <info>  Config: added 'anonymous_identity' value ''
NetworkManager[668]: <info>  Config: added 'bgscan' value 'simple:30:-65:300'
NetworkManager[668]: <info>  Config: added 'proactive_key_caching' value '1'
NetworkManager[668]: <warn>  sup-iface[0x5609a63bf980,wlp5s0]: assoc[0x5609a63c8f40]: failure to add network: invalid message format
NetworkManager[668]: <info>  device (wlp5s0): state change: config -> failed (reason 'supplicant-failed') [50 120 10]
NetworkManager[668]: <info>  manager: NetworkManager state is now DISCONNECTED
NetworkManager[668]: <warn>  device (wlp5s0): Activation: failed for connection 'eduroam'
NetworkManager[668]: <info>  device (wlp5s0): state change: failed -> disconnected (reason 'none') [120 30 0]
kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready
NetworkManager[668]: <info>  device (wlp5s0): set-hw-addr: set MAC address to 16:09:73:46:D9:3E (scanning)
kernel: IPv6: ADDRCONF(NETDEV_UP): wlp5s0: link is not ready

What I am doing wrong?

1

The problem was solved by removing this line:

anonymous-identity=

from /etc/NetworkManager/system-connections/conname.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.