-2

I've been experiencing a hard time with my kali rolling dist. It's been more that a week(or weeks?) that I have problems with this rolling version, one after another. Let's leave the fact that it simply could not be installed on my intel i7, nvidia 1050 notebook because of gpu discompatibility and ipv6 errors, weren't able to boot up live at least. But I am using VMware now, it works with that.

So, my main problem is that even though I have internet connection, sources.lst configured properly with only the official kali rolling rep, literally no matter what i want to install, zipalign, aptitude, android-sdk, wireguard (what has been added to kali rep not so long ago) it outputs either

E: Unable to locate package xyz

or

E: Package 'xyz' has no installation candidate.

But when I check if apt-get can access internet, it can, becasue it can check for example armitage has the newest version. apt-get update & upgrade acts like everything is fine and up to date. I am not using proxy. I can ping sites, browse in browser.
Tried several methods on this website, and others as well, none of them worked.

*PS:I have a whole line of things what fails to work properly on VMware either, ie.:gpu driver(yet its not fully installed bcuz of apt-get), bluetooth, wlan driver... There must be some serious bull**** going on with my luck on linux.*

Specs: ASUS FX503VD
Windows 10 Pro, VMWare Workstation 15 and Kali 2018.3
Intel i7 7700HQ
NVIDIA GeForce GTX 1050 4gb
8 GB RAM.

40 gb storage, 3gb swap, 3 cores, 3.5 gigs or ram was assigned to Kali in VMware.
Using bridge mode to share internet with guest.

closed as unclear what you're asking by Rui F Ribeiro, Henrik, Jeff Schaller, GAD3R, user88036 Oct 12 '18 at 0:07

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Thank you for your answer! Except the fact that it does not answer the specific problem, the packages i want to install are required to work with kali, so it does not change the facts. You are right, I'm not an expert, and I don't want to be. But i guess apt should work, and i feel it's not me that is the problem. – mpkfa Oct 11 '18 at 14:53
  • You say "sources.lst configured properly with only the official kali rolling rep";' please could you show the exact contents of your sources.lst in the question? – JigglyNaga Oct 11 '18 at 16:48
  • 1
    Possible duplicate of Why is Kali Linux so hard to set up? Why won't people help me? – Henrik Oct 11 '18 at 16:52
  • 'deb http.kali.org/kali kali-rolling main non-free contrib' just the one copied from the kali website, although i tried other variations as well. – mpkfa Oct 11 '18 at 17:54
1

Check that you have all the repos in working order in /etc/apt/sources.list, then do sudo apt-get update I can't comment so I can't really put this any simpler, but was it a typo when you said sources.lst?

  • the only rep in my sources.lst is the official by kali: 'deb http.kali.org/kali kali-rolling main non-free contrib', tried https version too. According to the website of kali, adding more repositories is not recommended, it might break the system. – mpkfa Oct 11 '18 at 15:31
  • It is source.list, by the way. that might be a problem – jkan5855 Oct 11 '18 at 19:16
1

The correct sources list is deb http://http.kali.org/kali kali-rolling main non-free contrib

Not the answer you're looking for? Browse other questions tagged or ask your own question.