4

I recently switched from Ubuntu 10.04 gnome to Debian wheezy Kde.

Everything's work fine, except to the Iceweasel/firefox custom protocols!

I added komodo.protocol in my ~/.kde/share/services with:

[Protocol]
exec=python /path/to/my/script.py "%u"
protocol=komodo
input=none
output=none
helper=true
listing=
reading=false
writing=false
makedir=false
deleting=false

This works for chrom(e|ium), but not for firefox.

I've read about firefox should use the gnome configs even under Kde, so I tried:

gconftool-2 -s /desktop/gnome/url-handlers/komodo/enabled --type Boolean true
gconftool-2 -s /desktop/gnome/url-handlers/komodo/command 'python /path/to/my/script.py %s' --type String

that used to work when I was on ubuntu, but it doesn't on kde.

Any idea?

EDIT

An example link: komodo:/var/www/app/0/Modules/Controller/Node/Controller_Node.class.php:1202

And if I run the command komodo /var/www/app/0/Modules/Controller/Node/Controller_Node.class.php:1202 from the terminal it works correctly; my python script simply check few things and then runs this command - but with firefox/iceweasel it never gets triggered.

0

You may try to edit Firefox configuration via about:config:

  • Tryed, still get the error "Address can not be interpreted, Unable to open this address: the protocol (komodo) is not associated with any program." – Strae Sep 10 '12 at 15:05
  • Can you give us an example of the link you click on? Also, clicking on the link should open the "Launch application" window with "This link should be opened with an application - Send to". This should be the easiest way to associate a protocol with a custom application. – Francesco Turco Sep 11 '12 at 10:18
  • I added an example. Actually, I do not want the "Launch Application", i use this protocol in my error_handlers scripts to automatically open the right file in the right position where the error occour. – Strae Sep 11 '12 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.