2

I have an old laptop (Asus n56v) that I turned into a home lab by installing Proxmox hypervisor, it works well and also WOL (wake on LAN) work.

I need to store it lid-closed because I only manage it through the terminal from another host anyway.

I have edited /etc/systemd/logind.conf and set HandleLidSwitch=ignore so now when I close the lid nothing happens which is good.

I can't seem to be able to have it wake on LAN when the lid is closed, only when it's opened.

the Proxmox is running under Debian stretch, running kernel 4.15.17-1-pve.

  • Perhaps because its in sleep-mode? – Sam Oct 11 '18 at 10:44
  • It's not in sleep mode in any stage, only turn on and then when work is done it's turned off completely (shutdown -h now) – Ilai Ben Amar Oct 11 '18 at 11:28
  • Im sorry, but I don’t fully understand your sentence. – Sam Oct 12 '18 at 9:22
  • It is not in sleep mode, not in any way. It's only turned on and turned off. No sleep mode. – Ilai Ben Amar Oct 12 '18 at 10:46
  • So it’s completely off? – Sam Oct 12 '18 at 11:27
0

I needed to so the same, and yes it can be done.

Debian's wiki provides two options:

  1. For systems which should never attempt any type of suspension, these targets can be disabled at the systemd level with the following:

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

  1. If you just want to prevent suspending when the lid is closed you can set the following options in /etc/systemd/logind.conf:
[Login]
HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore

I've tested with two laptops.

  • one laptop I set both 1. & 2.
  • the other laptop I only set 2.

WOL works in both cases, (laptops are powered off, their lids closed, WOL triggered --> both laptops (aka. proxmox nodes) boot up)

Very cool ;)

source: https://wiki.debian.org/Suspend

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.