1

I'm on Fedora 28 gnome desktop interface. Some time ago I mistakenly set the right Ctrl key as compose key.

Because of this, after every reboot, the right Ctrl key (rctrl) is inactive -- for e.g. rctrl+A won't take the cursor to the beginning of the prompt line when working in CLI or rctrl+W won't close an unnecessary tab in MozFirefox. setxkbmap -query produces

rules:      evdev
model:      pc105
layout:     it,it
variant:    ,
options:    compose:rctrl

Every time I must manually give setxkbmap -option to unset it or disable it, but after reboot it again reverts to compose:rctrl.

Is there a file I can edit to make the change permanent?


Content of file /etc/X11/xorg.conf.d/00-keyboard.conf

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "it"
        Option "XkbModel" "pc105"
EndSection

Content of file /etc/vconsole.conf

KEYMAP=it
FONT=eurlatgr
0

Run the "GNOME Tweaks" application. (Hit the overview key, type tweaks, and it should come up either as already installed or available to install in Software.)

In that application, find the Keyboard & Mouse tab. This is on F29 beta so it might be slightly different, but the concept is the same:

tweaks

Click where I've circled — it'll bring up this dialog:

compose key dialog

Where you can either turn the key off or select a different one. (Personally, I find this a lovely use for Caps Lock, although you can see I set it to Right Alt on my current system.)

  • This worked! Thanks mate! I wonder what is the CLI equivalent of GNOME-Tweaks. Is it gsettings etc.? – pgkt Oct 12 '18 at 8:12
0

The command you'll need is localectl.

I don't have Fedora 28 at hand for testing right now, but as the command syntax is:

localectl set-x11-keymap <layout> [model [variant [options]]]

I believe the command should be something like:

localectl set-x11-keymap it pc105

Leaving the variant and options slots empty will remove existing variant/options settings.

The settings might be stored in /etc/vconsole.conf for the console, and /etc/X11/xorg.conf.d/00-keyboard.conf for the X11 GUI. No clue about Wayland, but the localectl command is supposed to handle it all for you.

  • I tried that -- after reboot, I again find the option compose:rctrl. See content of /etc/X11/xorg.conf.d/00-keyboard.conf file posted in the OP. – pgkt Oct 10 '18 at 16:04
  • OK, then it might be your desktop environment maintaining its own set of keymap settings. This answer indicates you can wipe out GNOME's keymap tracking with gsettings set org.gnome.desktop.input-sources sources '[]'. – telcoM Oct 10 '18 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.