0

I have a laptop that contains two SSD disks. Legacy mode is completely disabled in BIOS, so I'm most likely using UEFI only.

The bigger disk was used to install a fresh copy of Windows. I then used Rufus to transfer Debian to my USB stick and was able to install Debian in UEFI mode.

When I reboot, I do not get grub, but it boots straight to Windows. If I press the F2 hotkey and then select to boot Debian - then grub magically appears. I can then select to boot to Windows or Debian.

I have already disabled fastboot and the command bcdedit /deletevalue {bootmgr} path \EFI\ubuntu\grubx64.efi is not helping me out at all.

How can I fix grub so that it's going to be shown?

0

This is not a problem with GRUB but with UEFI. UEFI is likely defaulting to Windows Boot Manager. You can change the default boot in UEFI settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.