0

I am using OpenSuse Leap 15.0 with KDE environment on a desktop that is connected to the LAN at my institute. The institute uses a proxy and the settings the system administrator asked to use is:

HTTP proxy: 172.16.0.1, port 3128.'

FTP proxy, SSL proxy and SOCKS host have the same settings. An authentication is also required i.e. I have a username and a password. I am connecting to the internet using Network manager.

I can browse websites perfectly using Firefox as the proxy settings and my username and password are saved in Firefox -- Preferences -- Network proxy -- Settings. However, whenever I try to use the OpenSuse package manager Zypper from the terminal, it fails to connect to any repository. After looking up this problem over the Internet, I understood that this is due to issues with proxy. The proxy settings are not applied globally.

I tried to set up the proxy through Yast -- Network services -- Proxy, but there proxy URL's are required which I don't have. I also tried to do the same through System settings -- Network -- Proxy. I chose the Manually specified proxy option and entered the proxy server details though there was no field for entering username and password. But immediately afterward, If I open System settings -- Network -- Proxy, I find that the system has automatically reverted back to No proxy.

Can anyone please guide me in setting up the proxy globally so that Zypper and other programs can connect to the internet?

0

The simplest way is to use Yast -- Network services -- Proxy.

The url you need is simply http:// + "your proxy ip" + : + "your proxy port" + /.

In your case, it is http://172.16.0.1:3128/.

P.S. Probably you should disconnect and reconnect to have your environment updated.

  • Thank you! With your settings, zypper has started working! However, in Yast there is no place for SOCKS proxy. Is it alright without that? Should I edit the file \etc\sysconfig\proxy with the url written in this way to include SOCKS proxy? I was wondering if instead of using Yast, one just chooses to edit the \etc\sysconfig\proxy then how is the username and password entered? – damaihati Oct 9 '18 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.