2

I can't boot my Debian 9.5 with following errors. If I remember correctly ACPI Errors were shown every time I turn on PC. But computer always boot right with these errors, so I didn't care much. The new error starts at "A start job is running.."

error 1st part

error 2nd part

When did the error start? I was going to sell my older HDD so I erased the disk /dev/sdd via command dd if=/dev/zero of=/dev/sdd bs=1M. The disk was mounted to /diskB_1TB. After erasing the HDD I turned down computer and then disconnected the disk from a motherboard. After that I turned on the computer but the error occured for the first time.

I've tried procedure from: https://askubuntu.com/questions/924170/error-on-ubuntu-boot-up-recovering-journal/924335?noredirect=1#comment1512824_924335 but it fixed nothing.

tried commands

I have 4 disks

  • /dev/sda with windows
  • /dev/sdb with linux debian
  • /dev/sdc as 2TB data disk
  • /dev/sdd as 1TB data disk (the former disk I erased and disconnected)

my disks

Is there anything I can still do in this situation? I'm pretty sure I did delete only /dev/sdd disk. I can still access data (via terminal) located in /dev/sdc and in /deb/sdb where my /home/stepaiv3 is located. Moreover I can normally boot into my windows on /dev/sda.

3

Systemd assumes certain mounts are critical to the system and as such a failure to mount one results in it switching to emergency mode.

Systemd should have reconfigured its automount units when the device was disconnected unless it appears in /etc/fstab or you configured it as a mount unit. So the issue is likely that you still have /diskB_1TB in your fstab.

From your emergency mode console try editing your fstab /etc/fstab and remove the line with /diskB_1TB then reboot.

  • Wow.... it was that easy! :D Thank you so much. After removing the line from /etc/fstab my Debian boot :) – kocourOggy Oct 9 '18 at 0:07
  • Good call. The bigger problem is that often this issue is not logged at all. – Rui F Ribeiro Oct 9 '18 at 1:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.