1

This query is actually a double duplicate. I initially queried several months ago, and I'm repeating this updated query in the hopes that things have changed. I recently posted a related query that was poorly formatted and omitted pertinent details. I've deleted that query and am re-posting.

Thanks to G-Man, jsotola, peterh, and undercat for their help/suggestions.


I am in the United States. There are several streaming video sites, including Cox Cable and HBO.com, that require a "Windows environment" and either Firefox or Chrome as a browser. I have both of those browsers installed on Fedora, but neither will work. I can dual-boot into Windows 7, but I would like to access these sites from within Fedora. Is this possible?

Here are things I've tried so far that didn't work:

  1. VirtualBox with guest additions running Windows 7 Professional.

    This mostly works, but with 1 core and 8GB of RAM the websites have choppy audio and video and my system temperature gets up to 45C. With a second core, the choppiness is mostly eliminated but the temperature spikes to 60C, and I suspect more cores/memory would be even worse. I don't want to habitually run at over 40C.

    I posted in a hardware oriented forum re

    a. a low cost (< $100) cooling solution; no joy. I received responses that low cost (significant) cooling is not viable.

    b. specifying more cores to Virtual Box; no joy. I received responses that after I had maxed the Virtual Box cpu-cores allocation, Virtual Box's processsing of the video stream would still be onerous enough to drive up the temperature. Apparently, the only effective cooling alternative is to stream the video outside of VirtualBox.

    Given a choice between consistently running upwards of 55C with VirtualBox(guest=Windows 7) or dual booting into Windows 7, I choose the dual boot. Therefore, I have to reject the VirtualBox alternative.

  2. Running ChromeSetup.exe via Wine to create a Wine-Chrome browser.

    Just re-tried on 10-8-2018, same result as several months ago: the setup hangs, messaging "can't connect to the internet".

  3. Changing Useragent

    Just re-tried on 10-8-2018. From within the google-chrome browser, I installed the user-agent-switcher package and then switched the user-agent from chrome to internet explorer 10. Still no joy trying to play an hbo movie.

  4. Install Firefox via wine, and then install flash.

    Just re-tried on 10-8-2018. The wine-Firefox install crashed.

  5. Test the https://help.vivaldi.com/article/netflix-on-linux/ article

    Just tried on 10-8-2018; no joy. I tested it on my chrome browser. I was able to play the test page drm videos, but hbo streaming is still dead in the water (from fedora 26).

  6. Use Ubuntu 18.04 and Google Chrome not chromium.

    It was reported that free episodes of hbo.com played ok under Ubuntu 18.04 (browser=google-chrome) and suggested that perhaps the problem was missing codecs in my Fedora install. Since I was able to watch hbo-go movies from within VirtualBox(guest=Windows7), it seemed reasonable to experiment with VirtualBox(guest=Ubuntu 18.04, browser=google-chrome).

    Just experimented on 10-8-2018. Yes hbo.com's free trailers play ok, but no hbo-go movies still do not; result is blinking dots rather than the movie stream.

    This inconclusively suggests that I do not (? also) have a missing codecs problem. When I installed Fedora 26, I followed the standard suggestion re installing additional codecs and then installing the VLC media player. Since the installation, I've played movies in fedora 26 with no problem. Unsure whether there are other codecs that I am missing.

  7. clarification of some of my attempts

    I have tried both firefox and chrome. For each, I tried both with or without user agent switching. On none of these 4 attempts was I able to stream an hbo-go movie from within fedora. Also, I attempted a wine-install of the windows version of both firefox and chrome. Both wine-installation attempts failed.

  8. it was suggested that I should explore widevine.

    On 10-9-2018, I reviewed https://docs.fedoraproject.org/en-US/quick-docs/installing-chromium-or-google-chrome-browsers/ Then, in a Fedora (bash) terminal, I executed the dnf install chromium command to install chromium. Then I verified that /usr/lib64/chromium-browser/ (already) contains both libwidevinecdm.so and libwidevinecdmadapter.so. Then, no joy re-trying hbo-go. I then installed the flash plugin into the chromium browser, closed and re-opened the browser, and re-tried hbo-go; again no joy. In both cases, hbo-go showed the message "plugin not supported."

    See also jdwolf's remark in the comment section.

How should I proceed?

  • Comments are not for extended discussion; this conversation has been moved to chat. – terdon Oct 9 '18 at 8:51
  • It isn't though. Long comment chains are very hard to read through. Moving it to chat makes it easier to communicate. – terdon Oct 9 '18 at 13:32
  • Netflix uses Widevine directly via Encrypted Media Extensions and has an HTML5 player which also means the browser needs to support h264 while others still require Flash or Silverlight support. I believe HBO Go requires Flash and uses DRM through it. Those still using Flash might be using Adobe Primetime for DRM which does not support Linux at all. If its using Widevine then as long as Flash is installed it should work. – jdwolf Oct 10 '18 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.