0

My computer freezes every 1 or 2 seconds for a short period as well. So 1 or 2 seconds working and 1 or 2 seconds not working.

Everything stops working except for the mouse.


The first time I discovered the problem was when I wanted to open a 1GB txt file with leafpad. The syslog (and other files) raised to 350MB with leafpad errors. I still don't really think it could be the cause but since then I have noticed it slow.

I tried deleting those lines to make the files lighter but didn't work (ofc).

The line was a repetition of:

localhost leafpad[6934]: pango_tab_array_get_tab: assertion 'tab_index >= 0' failed

Gnome-shell debugging (In the end I think the problem is not there)

I have runned top to see the problem and my first guess was that gnome-shell. I have disabled all extensions on gnome and I have put Hidden=True on the gnome tracker. Reboot ofc but issue still continues.

top - 11:37:47 up 16 min,  1 user,  load average: 5.08, 4.53, 3.07
Tasks: 186 total,   1 running, 185 sleeping,   0 stopped,   0 zombie
%Cpu(s):  5.4 us, 13.6 sy,  0.0 ni, 78.8 id,  2.2 wa,  0.0 hi,  0.0 si,  0.0 st
MiB Mem :  11894.0 total,   9255.9 free,    884.7 used,   1753.4 buff/cache
MiB Swap:      0.0 total,      0.0 free,      0.0 used.  10597.3 avail Mem 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND    
 1467 root      20   0 3828560 258004  73056 S  16.9   2.1   3:00.91 gnome-she+ 
 1627 root      20   0  384600  23668  17328 S  13.0   0.2   1:31.00 gsd-xsett+ 
 1732 root      20   0 1190848  66960  31648 S  11.6   0.5   1:21.92 gnome-sof+ 
 2371 root      20   0  239576  28532  22080 S   9.0   0.2   0:49.61 leafpad    
 2282 root      20   0 1397692  79500  38488 S   8.3   0.7   2:27.84 nautilus   
 1618 root      20   0  452484  40448  13752 S   7.6   0.3   1:01.97 packageki+ 
 1643 root      20   0  384156  24452  17428 S   5.3   0.2   1:16.62 gsd-keybo+ 
 1636 root      20   0  236512  22152  17128 S   3.0   0.2   1:16.76 gsd-clipb+ 
 1269 root      20   0  343084  47552  32060 S   0.7   0.4   0:19.31 Xorg       
    9 root      20   0       0      0      0 I   0.3   0.0   0:01.07 rcu_sched  
 1176 message+  20   0   18272   5276   3476 S   0.3   0.0   0:01.51 dbus-daem+ 
 1640 root      20   0  550896  24776  19364 S   0.3   0.2   1:18.79 gsd-color  
 2850 root      20   0  527664  39564  28252 S   0.3   0.3   0:07.43 gnome-ter+ 
 3048 root      20   0   15804   3484   3040 R   0.3   0.0   0:00.01 top        
    1 root      20   0  192548   9036   6632 S   0.0   0.1   0:02.95 systemd    
    2 root      20   0       0      0      0 S   0.0   0.0   0:00.00 kthreadd   
    3 root       0 -20       0      0      0 I   0.0   0.0   0:00.00 rcu_gp 

I have used the following to know where the issue was and it seeams openat takes the majority. What also get's my attention is the amount of errors that function gets and I guess that might be the problem.

strace -c -p 1467
strace: Process 1467 attached
^Cstrace: Process 1467 detached
% time     seconds  usecs/call     calls    errors syscall
------ ----------- ----------- --------- --------- ----------------
 38.35    2.269925          65     34909     22415 openat
 21.63    1.280485        1583       809       252 unlink
 18.82    1.113966        4700       237        15 link
 16.79    0.993957        4498       221           rename
  0.96    0.056549           2     30633     21313 access
  0.91    0.053897           3     20006       186 stat
  0.47    0.027686           1     19059           read
  0.42    0.024586           2     12498           close
  0.33    0.019538           2     10852           fstat
  0.28    0.016418           5      3083           munmap
  0.21    0.012386           4      3099           mmap
  0.18    0.010921          21       528           write
  0.13    0.007561           1      7413           getuid

So I killed the gnome-shell process and still the problem remains. I don't really see what the problem may be and I have a 4 cores intel i7 processor pc so it shouldn't be so demanded.


iostat -h
Linux  10/11/2018   _x86_64_    (4 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
          24.4%    0.4%   21.4%   10.8%    0.0%   43.0%

      tps    kB_read/s    kB_wrtn/s    kB_read    kB_wrtn Device
    11.14       175.3k         0.0k      16.6M       0.0k sda
   235.07         6.6M         2.9M     641.9M     286.4M sdb
   769.76       789.5k         0.0k      75.0M       0.0k loop0
  • Switch to another DE. Gnome is one of the heaviest DEs out there. Try XFCE or LDXE if you want something really light without the eye candy. Try KDE if you want something a bit heavier but nicer, and try (my personal favorite) Cinnamon if you want good HiDPI support in a light DE. – Stiffy2000 Oct 8 '18 at 11:55
  • @Agustin CPU usage is not very high but the load is. How many CPU (cores) do you have? Could you paste output of iostat -h ? – mrc02_kr Oct 8 '18 at 12:21
  • You mention "The syslog (and other files) raised to 350MB with leafpad errors". Could you include a few of those errors in your question? – JigglyNaga Oct 11 '18 at 9:07
  • I've answered editing the question itself. – Agustin Barrachina Oct 11 '18 at 15:54
0

The main process that will eat your CPU in GNOME is tracker-miner-fs

Try disabling it with the instructions here.

  • Hi @Stiffy2000. What make you think that in this case this process uses a lot of CPU? High CPU usage by one process doesn't explain freezing. – mrc02_kr Oct 8 '18 at 11:59
  • This happened to me in GNOME before I turned off tracker-miner-fs, but there were still problems. The freezing happened a lot less, but still happened. – Stiffy2000 Oct 8 '18 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.