0

I'm going to install puppet (puppet master) in a CentOs v7 Server which is running on google cloud. I am facing a issue with downloading the puppet tarball into my server.

Once I use below command,

wget https://pm.puppet.com/cgi-bin/download.cgi?arch=x86_64&dist=el&rel=7&ver=latest

It is downloding the .CGI file. not the Tar ball. But once I hit the url it download the respective tar file

  • It does not work because ? and & are special characters to the shell, and need to be escaped. Keep it in mind for future similar problems – Rui F Ribeiro Oct 7 '18 at 7:20
1

Did you try quotes on the URL?

For me this command starts to download 472MB of puppet-enterprise-2018.1.4-el-7-x86_64.tar.gz

wget -O puppet-enterprise-2018.1.4-el-7-x86_64.tar.gz 'https://pm.puppet.com/cgi-bin/download.cgi?arch=x86_64&dist=el&rel=7&ver=latest'

If that doesn't help, then there are probably some cookies needed. If you have SSH access to the machine, download the file to your local machine and use scp to copy it to the remote machine.

  • Thanks, It worked after adding quotes on the URL. And I was thinking to do it in second way with SCP option. How ever it worked with quotes, Somehow I missed to add, Thanks !! – Ishara Kularatna Oct 7 '18 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.