1

I've upgraded (from Trisquel 7.0) to Trisquel 8.0 with clean/fresh install.

When I connected to printer (HP LaserJet P1007) it's detected while adding from settings>printers (system-config-printer) and I completed the setup;at last it asked whether to print test page and it was not printed. I also tried printing documents but they are not really printed and system shows printed successfully.

Though it displays correctly added/configured in settings:

enter image description here

enter image description here

I'm not sure but earlier I had faced similar problem when I solved it by manually configuring through hp-setup as discussed here. I've also tried that but it's showing following error:

error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

So,(looking at it would be the issue with GUI provided by Qt4), I tried interactive mode:

$ hp-setup -i

HP Linux Imaging and Printing System (ver. 3.16.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)
  2         par         Parallel Port (LPT:)                                      

Enter number 0...2 for connection type (q=quit, enter=usb*) ? 0

Using connection type: usb

error: No device selected/specified or that supports this functionality.

Hence the error is "No device selected/specified or that supports this functionality."

I've also checked that hp-plugin is installed properly because I remember my printer needs plugin:

$ hp-plugin -i

HP Linux Imaging and Printing System (ver. 3.16.3)
Plugin Download and Install Utility ver. 2.1

-----------------------------------------
| PLUG-IN INSTALLATION FOR HPLIP 3.16.3 |
-----------------------------------------

The driver plugin for HPLIP 3.16.3 appears to already be installed.
Do you wish to download and re-install the plug-in? (y=yes*, n=no, q=quit) ? n

Thus, how do I fix the issue of 'jobs are not printing and it's shown printing completed' and 'hp-setup not working'?

Note: I've also tried purging and re-installing hplip and here is the version of package available on Trisquel's repository:

$ apt-cache policy hplip
hplip:
  Installed: 3.16.3+repack0-1+8.0trisquel1
  Candidate: 3.16.3+repack0-1+8.0trisquel1
  Version table:
 *** 3.16.3+repack0-1+8.0trisquel1 500
        500 https://archive.trisquel.info/trisquel flidas-updates/main amd64 Packages
        100 /var/lib/dpkg/status
0

Finally I concluded that hp-setup is not working and setting up with hp-setup is the only way. So, I purged the pre-installed version of hplip (3.6.13) and planned to try with (latest) version (3.18.9) available at the official site of HPLIP. As plugin is also required I needed to download hplip-3.18.9-plugin.run and hplip-3.18.9-plugin.run.asc in addition to hplip-3.18.9.run.

Then I installed sudo sh /path/to/hplip-3.18.9.run which required some dependencies and many of them could not be installed by the installer and I manually installed them. This consumed much time for me to find and install dependencies, though all of them are free and available on Trsiquel repository. Finally hplip (3.18.9) installed successfully. Now, hp-setup (provided by hplip 3.18.9) worked fine and configured/set HP printer fine.

I exactly don't know/understand what was the problem with pre-installed version and plugin but this is how I ultimately made printer working. So, adding as an answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.