0

I'm running Linux Mint 19, Cinnamon. This particular issue has existed on mint 18 as well as Mate and Cinnamon desktop environments

The problem is this:

I have a single drive partitioned into multiple parts. One partition is formatted NTFS for sharing data between windows and linux in a dual boot environment

In Mint, the shared Data partition automounts on startup, BUT I cannot launch any applications, and Launchers do not appear...

UNTIL I open the file manager and literally "click" the partition. As soon as I do that, the partition becomes available, all programs can be loaded, and launchers work.

Why is this required? Since it is automounted (Mount options in Disks confirms this), shouldn't it be available immediately?

These are the mount options nosuid,nodev,nofail,x-gvfs-show

  • Do you have an entry for that partition in /etc/fstab? What does it look like? – rudib Oct 4 '18 at 22:37
  • It looks like there is only an entry for the linux partition 6, but not for partition 7 which is that shared data partition. Good find. What would I need to do to construct a proper entry for it, and what does this fstab file do? Partition 6 entry looks like this UUID=long-uuid-here / ext4 errors=remount-ro 0 1 – TetraDev Oct 5 '18 at 21:42
  • 1
    Basically UUID=the-uuid /the/folder ntfs defaults 0 1 should get you going. Unless you need special options or want to mount it readonly. After that running mount -a should mount it to the directory. – rudib Oct 5 '18 at 21:51
1

Thanks for the help from @rudib I figured it out. I realized that by unchecking "User Session Defaults" in the Disks program, it would write a new line to the /etc/fstab file, and properly fill out the line with the options needed for it to mount correctly. Now it works! Thanks. Mint should do this by default, in my opinion.

enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.