2

We recently upgrade our internet provider which now comes with 2.4Ghz and 5Ghz wifi. I can connect properly on 2.4Ghz while on 5Ghz I am experiencing random "lags" in the connection. More specifically, the network manager is not disconnecting from the router however to refresh a page in a browser when the lag strikes it needs 7-30 seconds. Some times ssh connection is dropped too. This is happening in a random manner but usually every 3-5 minutes. I tried to change the 5Ghz channel with no luck. The rest of the devices in the house are not experiencing any issues.

I 've already tried to reinstall Intel 3160 drives from backports as well as to reinstall the linux-image with no luck. I 've also disabled wifi.powersave to wlan0 with no luck.

Does anyone have an idea how to solve or debug this issue?

These are some system information:

uname -a:

Linux debian 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u5 (2018-09-30) x86_64 GNU/Linux (Debian stretch)

lshw -C network:

*-network
       description: Wireless interface
       product: Wireless 3160
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 93
       serial: 34:e6:ad:be:63:65
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.9.0-8-amd64 firmware=17.948900127.0 ip=192.168.0.17 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:49 memory:c1000000-c1001fff

iwconfig:

wlan0     IEEE 802.11  ESSID:"BRA****"  
          Mode:Managed  Frequency:5.56 GHz  Access Point: F8:AB:05:00:1E:DE   
          Bit Rate=390 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:125   Missed beacon:0

ifconfig:

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.17  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::36e6:adff:febe:6365  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:8109:a3c0:55af:36e6:adff:febe:6365  prefixlen 64  scopeid 0x0<global>
        ether 34:e6:ad:be:63:65  txqueuelen 1000  (Ethernet)
        RX packets 415816  bytes 507186123 (483.6 MiB)
        RX errors 0  dropped 2  overruns 0  frame 0
        TX packets 144134  bytes 31353570 (29.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisi

lspci -k -nn | grep -A 3 -i net:

03:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b4] (rev 93)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8270]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

modinfo iwlwifi:

filename:       /lib/modules/4.9.0-8-amd64/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
license:        GPL
author:         Copyright(c) 2003- 2015 Intel Corporation <linuxwifi@intel.com>
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-6.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265D-26.ucode
firmware:       iwlwifi-7265-17.ucode
firmware:       iwlwifi-3168-26.ucode
firmware:       iwlwifi-3160-17.ucode
firmware:       iwlwifi-7260-17.ucode
firmware:       iwlwifi-8265-26.ucode
firmware:       iwlwifi-8000C-26.ucode
firmware:       iwlwifi-9000-pu-a0-lc-a0--26.ucode
firmware:       iwlwifi-9260-th-a0-jf-a0--26.ucode
firmware:       iwlwifi-9000-pu-a0-jf-a0--26.ucode
firmware:       iwlwifi-Qu-a0-jf-b0--26.ucode
alias:          pci:v00008086d00002720sv*sd00000A10bc*sc*i*
alias:          pci:v00008086d0000A370sv*sd00001030bc*sc*i*
alias:          pci:v00008086d00002526sv*sd00001030bc*sc*i*
alias:          pci:v00008086d000031DCsv*sd00000030bc*sc*i*
[...]
depends:        cfg80211
retpoline:      Y
intree:         Y
vermagic:       4.9.0-8-amd64 SMP mod_unload modversions 
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 4K for other devices 1:4K 2:8K 3:12K (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (default: 0 dB) (int)
parm:           nvm_file:NVM file name (charp)
parm:           d0i3_disable:disable d0i3 functionality (default: Y) (bool)
parm:           lar_disable:disable LAR functionality (default: N) (bool)
parm:           uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)
parm:           d0i3_timeout:Timeout to D0i3 entry when idle (ms) (uint)
parm:           disable_11ac:Disable VHT capabilities (default: false) (bool)
  • I don’t know the solution to your problem but can tell you that I’m experiencing the same problem on OpenSUSE Tumbleweed. – Tim Friske Oct 4 '18 at 12:41
  • So I am not alone. Is your inteface made by Intel? If yes, which product? – peterpanx Oct 5 '18 at 12:21
  • Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78); Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:0010]; Kernel driver in use: iwlwifi; Kernel modules: iwlwifi – Tim Friske Oct 5 '18 at 16:17
2

It seems that problem was the wifi adapter driver. I successfully solved the issue by upgrading the Kernel to the latest version (4.18) that is included in the stretch-backports repository.

Apt should have backports sources enabled

for Debian Stretch, append the following in /etc/apt/sources.list :

deb http://ftp.debian.org/debian stretch-backports main contrib non-free
deb-src http://ftp.debian.org/debian stretch-backports main contrib non-free

then install the kernel:

sudo apt update && sudo apt -t stretch-backports install linux-image-4.18.0-0.bpo.1-amd64 linux-headers-4.18.0-0.bpo.1-amd64

and reboot to load the new kernel.

  • Not really solved my problem. I have the same exact issue with Debian Buster and I already have Linux 4.19 installed. I still get those strange lag strikes for a couple of seconds almost every link I try to open. – David Tamar Jun 9 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.