0

I had a Manjaro, I shrinked its partition, changed the partition table to GPT (from MBR), installed Windows 7 in the space left from shrinking. The windows boot loader worked fine. (Everything up to this point has worked fine and i haven't had any problems)

I installed grub. Manjaro boots up alright, but when i boot into windows, the graphics are messed up and blurry, i will put a picture as i cant explain it accurately.

I'm using a UX410U Asus notebook, which has a NVIDIA GeForce MX130. (I confirmed that through lspci too)

(you can also see the mouse icon covered in random strips and repeated across the screen) picture

  • Try to boot in bios/legacy mode, not efi. Windows, especially earlier versions (up to and including 7) have problems with uefi. – jimmij Oct 4 '18 at 7:47
  • @jimmij The windows installation persists that the partition table should be GPT so an EFI boot loader can be installed and also, the windows boot loader was installed on an EFI format as well (which worked fine) so i doubt that would be the problem. – Ali Ameli Oct 4 '18 at 7:57
  • My windows 7 professional on GPT boots only if legacy first mode is enable in bios, otherwise screen stuck on early stage (although windows load normally, sound is playing, and I can do stuff "blindfold") . I was fighting with this a lot and eventually gave up. If you google a little you will find people complaining all the time about uefi problem in win7. Perhaps you have different issue, but trying won't hurt. – jimmij Oct 4 '18 at 8:17
  • jimmij is leading you up the garden path, and bootstrapping Windows NT is not a Unix and Linux subject. superuser.com/a/373864/38062 superuser.com/a/382650/38062 superuser.com/a/298960/38062 superuser.com/a/320244/38062 superuser.com/a/373457/38062 – JdeBP Oct 4 '18 at 10:33
0

Seems like @jimmij made a point. I managed to boot windows through the boot loader it had installed on the EFI partition (which was not removed by grub, and was recognized by my motherboard)

This solves my problem, as i just wanted to boot into both windows and manjaro.

But as for sticking to the UEFI boot loader, it seems that an MBR bootloader installed on an EFI partition could solve the problem. (equivalent of loading in legacy mode i guess?) Which, is another question, but the links shared by @JdeBP could give a lot of insight (or possibly solve, i didnt go through all of the contents) on that question.

Though still open to any solution that might work within the context of using grub and UEFI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.