0

I am having some problems starting Google Chrome on Ubuntu 18.04, and it seems to have something to do with my GPU driver--however, I do not know for sure.

I tried google-chrome from the command line, and it gave me the following;

theo@nitrates:~$ google-chrome
[29617:29617:1003/171104.939355:ERROR:sandbox_linux.cc(379)] InitializeSandbox() called with multiple threads in process gpu-process.
[29617:29617:1003/171105.478055:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.490579:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.531946:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.569271:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.585473:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.595687:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.665439:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.678878:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.869643:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171105.908701:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171106.012723:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171106.014180:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171106.030990:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171106.041881:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!
[29617:29617:1003/171106.062463:ERROR:gl_surface_presentation_helper.cc(161)] GetVSyncParametersIfAvailable() failed!

Some important things to note:

  1. There seems to be (some) unpredictability in this issue. Several times I have simply clicked on chrome or started it from the command line, and it starts up just fine. It is almost as if it goes through phases of working and not working.
  2. There seems to be a slightly higher rate of success when attempting to start it right after the computer has restarted / woken up from being shut down.
  3. This is a MacBook Pro from 2010 (15 inch retina), with the NVIDIA GeForce GT 330M and the "Intel HD Graphics with 256 MB of DDR3 SDRAM" as per this site.

EDIT:

Tried google-chrome --use-gl=osmesa --disable-gl-drawing-for-tests as recommended in this answer, and got the following error:

[1416:1416:1003/175305.577073:ERROR:gl_implementation.cc(291)] Failed to load /opt/google/chrome/libosmesa.so: /opt/google/chrome/libosmesa.so: cannot open shared object file: No such file or directory
[1416:1416:1003/175305.579670:ERROR:viz_main_impl.cc(236)] Exiting GPU process due to errors during initialization
[1361:1379:1003/175305.581582:ERROR:service_manager_context.cc(270)] Attempting to run unsupported native service: /opt/google/chrome/content_gpu.service
[1361:1361:1003/175306.061430:ERROR:gpu_process_transport_factory.cc(1007)] Lost UI shared context.
  • Hello @Theodore Weld. Did you see this issue in previous versions of google chrome? or just after and upgrade to a newer version? – user88036 Oct 4 '18 at 0:38
  • @Goro I do not know if this has something to do with an update necessarily. Currently I am on 69.0.3497.92 and have not ever updated it myself since installation. – Theodore Weld Oct 4 '18 at 0:44
  • 1
    Yeah so it seems that that file does not exist, I will update my answer with the error as that would be a nicer way to see it. – Theodore Weld Oct 4 '18 at 0:55
  • @Goro I did check this—doesn’t seem to be there. – Theodore Weld Oct 4 '18 at 0:59
  • There are many different releases of libgles2-mesa for Ubuntu 18.04 try the closest to your system. – user88036 Oct 4 '18 at 1:02
3

I would suggest that you do the following:

1) Check whether you have "libgles2-mesa" installed? If not, then install it.

2) Try disabling GPU-accelerated compositing under the flag "--use-gl=osmesa" using the command:

google-chrome --use-gl=osmesa --disable-gl-drawing-for-tests 
0

Install NVidia drivers:

1) ubuntu-drivers devices

2) sudo apt install nvidia-driver-(your device) -or- sudo ubuntu-drivers autoinstall

3) reboot

  • Is ubuntu-drivers devices a command to be typed?   Please do not respond in comments; edit your answer to make it clearer and more complete. – G-Man Dec 19 '18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.