0

I'd like to install the GNU software proview in one of my 2 computers running Debian. Unfortunately I'm unable to either install the binaries nor compile from source.

For information, when I use uname -a the linux version is this:

Linux <name> 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux

1) Install the binaries I downloaded pwr55_5.5.0-1_amd64.deb from the download page. But installing with gdebi or dpkg -i fails because of a dependancy on libmysql++

pwr55 dépend de libmysql++3 (>= 3.2.1+pristine-1) ; cependant : Le paquet libmysql++3 n'est pas installé.

Translates to (approximately)

pwr55 depends on libmysql++3 (>= 3.2.1+pristine-1) ; it is dependant on the package libmysql++3 it is not installed.

However this dependency will never be met because the package does not exist any longer and has a new name. An attempt to install the libmysql++package with apt-get install libmysql++ returns

libmysql++3v5 is already the newest version (3.2.2+pristine-2).

2) Compile from sources

Unfortunately compiling from sources doesn't work any better. According to the (outdated) documentation in the build-howto.info they built it with the now old gcc 4.3.2. I myself have an updated gcc 6.3.0 installed, and it is not possible to downgrade with this distribution.

I have a compile error, probably due to how gcc changed in the meantime.

Compiling ../../co_xml_parser.cpp
../../co_xml_parser.cpp: In member function ‘void* co_xml_parser::next_token()’:
../../co_xml_parser.cpp:80:21: error: cannot convert ‘std::basic_istream<char>::__istream_type {aka std::basic_istream<char>}’ to ‘void*’ in assignment
     c_sts = fp.get(c);
                     ^

I am thus unable to install the binaries and unable to compile source code. Hope to fix the source code by myself in a project I know nothing about is very slim. What can I do about this ?

  • 1
    I don't know how, but you could make a deb, that depends on the new name for libmysql, and claims to provide the old name for it. Then install it. It will cause the libmysql to be installed, and make apt, think that you have it installed by the old name. It may however break, if not compatible. – ctrl-alt-delor Oct 3 '18 at 16:01
  • @ctrl-alt-delor that might be a bit difficult given that libmysql++3v5 conflicts with and replaces libmysql++3 ;-). – Stephen Kitt Oct 3 '18 at 16:08
  • Well you could try to ignore the dependency and hope for the best that mysql is still being found and usable by proview: dpkg -i --ignore-depends=libmysql++3 pwr55_5.5.0-1_amd64.deb – Fiximan Oct 4 '18 at 12:29
  • Well, it "works" in the sense that it says the package is installed, but I cannot find any executable anywhere, and apt suggest removing those package when invoked (for example apt-get install -f says Les paquets suivants seront ENLEVÉS : pwr55 pwrdemo55 0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour. 1 partiellement installés ou enlevés. – Bregalad Oct 4 '18 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.