0

http://web1.heissa.de/usb2_speed.pdf

From the spec, I would expect a max. write rate of 60 Mbyte/s.

But today a simple test told me it‘s 226 MB/s. Is it possible that this is a trick of kernel 4,18 and the real write flush follows later and my test is not valid?

Specification:

USB 2.0 ,480 Mbit/s (60 MByte/s)
USB 3.0 ,5 Gbit/s (625 MByte/s)

So my first test was to check the usb2 speed of my Dell Inc. Latitude E6420, BIOS A23 01/04/2016 and indeed it‘s 480 Mbit/s.

cat /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/speed
480
3
  • Disable write cache, write directly onto disk then test again. Oct 3, 2018 at 13:21
  • Very good, thanks a lot that works:hdparm -W0 /dev/sdb /dev/sdb: setting drive write-caching to 0 (off) write-caching = 0 (off) root@oc:~# time dd if=/dev/urandom of=/srv/dev-disk-by-id-ata-FUJITSU_MJA2320BH_G2_K92MT9C29J5D-part2/rand1.txt bs=1G count=30 dd: warning: partial read (33554431 bytes); suggest iflag=fullblock 0+30 records in 0+30 records out 1006632930 bytes (1.0 GB, 960 MiB) copied, 112.356 s, 9.0 MB/s real 1m52.466s Oct 3, 2018 at 13:41

1 Answer 1

1

solved!

hdparm -W0 /dev/sdb

/dev/sdb: setting drive write-caching to 0 (off) write-caching = 0 (off)

time dd if=/dev/urandom of=/srv/dev-disk-by-id-ata-FUJITSU_MJA2320BH_G2_K92MT9C29J5D-part2/rand1.txt bs=1G count=30 dd: warning: partial read (33554431 bytes); suggest iflag=fullblock 0+30 records in 0+30 records out 1006632930 bytes (1.0 GB, 960 MiB) copied, 112.356 s, 9.0 MB/s

real 1m52.466s

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .