0

I am using Mint. Everything was fine until three days ago. I wanted to create a file but I discover that my external HDD has read-only mode (file system is NTFS). I didn't change anything before but OK, maybe it was just a little error. I fix it pretty quickly. But even now I can't create any file or directory, also I can't edit any existing file (actuality I can but file get error and I get senseless combination of random symbols and "\00\00\"). When I try to create text file or directory I get next error:

root@mint:/media/mint/A47A802C7A7FF97E# cat > text.txt
bash: text.txt: No such file or directory
root@mint:/media/mint/A47A802C7A7FF97E# mkdir -p directory
mkdir: cannot create directory ‘directory’: No such file or directory

Running with sudo also doesn't help. It worked thousand times before but not now. Is my drive gone or I do something wrong? I found a lot of different solutions but there is no my one. I hope there is really simple way to fix that.

UPD: I am sure that drive is really rw. But I run ntfsfix --no-action /dev/sdX and get

NTFS signature is missing.
Unrecoverable error
Volume is corrupt. You should run chkdsk.
No change made

Also sudo fsck /dev/sdX detected a difference between original boot sector and its backup.

  • 1
    "I discover that my external HDD has read-only mode. I didn't change anything before but OK, maybe it was just a little error." "Little errors" don't happen like that. Probably the system detected fs corruption and automounted it read-only. "I fix it pretty quickly." How? Which commands did you run? – dr_ Oct 3 '18 at 12:30
  • 1
    Try posting the output of cat /proc/mounts/. Also do a stat /media/mint/A47A802C7A7FF97E. This path may not exist(and still be the working directory of the shell) as these folders usually are created dynamically. – rudib Oct 3 '18 at 12:42
  • @dr01 I run sudo mount -o remount,rw /media/mint/A47A802C7A7FF97E so I should be able to create file and directories, isn't it? – senchetski Oct 3 '18 at 14:05
  • @rudib Path really exist. Moreover, last modified is dated September, 30th - right before the day my problem had begin. – senchetski Oct 3 '18 at 14:11
  • 1
    sudo mount -o remount,rw will attempt to mount as rw, but if there is a problem, it may fall back to ro. That's why cat /proc/mounts/ might give us a hint. – rudib Oct 3 '18 at 14:31
0
  • Ensure that there is no hardware problem: Check this with smartctl -a /dev/sdX. (You may have to installl smartctl first). Also check the output of dmesg | tail.

  • Warning, read carefully: Note that all that actions may/will change the data on the disk and might cause more damage. If possible, you should make a raw backup (with ddrescue for example) of the disk to an unrelated storage medium before changing anything. Proceed at your own risk.

  • Try to fix the filesystem: You can try to run ntfsfix /dev/sdX. You can also use the tool testdisk to attempt a fix. It has more options and is interactive.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.