0

I'm trying to install Ubuntu 18.04 on my ASUS F556U laptop without success. I already asked other questions on the subject, thinking that the problems were by UEFI mode. Well surpassed that, I already discovered that the problem is of the laptop, a professional I assure to me that it can be problem of Targeta Grafica, is not compatible with Linux. Well, since I can not install 18.04 install 16.04 but when updating it is broken and there is an error in the screen that I can not distinguish well, which I show: PCIe Bus Error: severity = Corrected, type = Physical Layer, id

When installing 16.04 it works perfectly, but it notifies me of. I've been with the problem for almost two months, and now I can not buy another laptop, if it does not work for Linux. I already tried other Linux distributions, and it gives me the same error. Now it gives me another problem, a message saying that I have little space in the root file system, only 924 MB, when I leave 150 GB. I show you screenshots of the errors you asked me to send to Ubuntu

The partner @oldfred helped me with his comments in another question I asked, but ASUS does not give me support for UBUNTU, to be able to update the BIOS. I do not know if I am adding PCI = NOMSI correctly, because when I update, the error of the first image that I am attaching is shown on the screen.

I was also told to update the UEFI, but since ASUS does not support me, I do not know how to do it from Ubuntu

enter image description here enter image description here enter image description here enter image description here

closed as unclear what you're asking by Rui F Ribeiro, RalfFriedl, JigglyNaga, Romeo Ninov, user88036 Oct 11 '18 at 0:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Updating firmware is usually done from Windows in whatever your vendor supports it. Since it is Windows, I pretty much doubt it is on topic here. – Rui F Ribeiro Oct 2 '18 at 18:24
0

Thanks for the support. I resolve myself thanks to the answer of another question that answered @oldfred. Almost all systems need to have UEFI/BIOS updated to latest available from vendor. So first thing to check is if UEFI/BIOS is latest version from vendor. Normally there is only one version and it may say Windows. But Microsoft requires vendors to allow users to turn off UEFI Secure Boot. But even if UEFI Secure boot is on, Ubuntu should install. But proprietary drivers may require you to turn off Secure Boot.

Many Asus models need a boot parameter pci=nomsi. On initial boot you can manually add it to grub menu. But if a parameter is always required you will want to make it permanent by editing this and then updating grub.

https://wiki.ubuntu.com/Kernel/KernelBootParameters

sudo nano /etc/default/grub sudo update-grub

Change this in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

Similar systems with issue: ASUS X540U pci=noaer instead of pci=nomsi and it also worked

https://ubuntuforums.org/showthread.php?t=2391201

Problems Installing on ASUS F555U needed boot option pci=nomsi

http://ubuntuforums.org/showthread.php?t=2303665

Asus x555u w/o pci=nomsi - space issue on drive and runaway log files filling drive

https://ubuntuforums.org/showthread.php?t=2327103&page=3

https://ubuntuforums.org/showthread.php?t=2327570

Source:

https://askubuntu.com/questions/1079540/how-to-install-ubuntu-on-asus-f556u-journalerror-error

Thanks for the support. I resolve myself thanks to the answer of another question that answered @oldfred. Source I hope it serves other users, for me it was two months of unsuccessful attempts until it appeared @oldfred

Not the answer you're looking for? Browse other questions tagged or ask your own question.