1

I'm trying to install a specific version of Firefox (52.8) on Centos 6.9. I've used "yumdownload --resolve firefox...x86_64". It created a folder the firefox rpm as well as 5 or six other dependencies. These included nspr-4.19 and several nss-3.6 rpms.

When I tried to install it on another system (using rpm -ivh firefox..x86-64.rpm), it had a dependency conflict with existing nspr (a lower version). When I tried to uninstall the existing version, it said it would delete a bunch of important modules.

What's the best solution? Should I try to do an rpm update on the underlying modules? If so, do I specify the older one or the newer one?

  • What is preventing the use of a newer version of the browser? – dsstorefile1 Oct 1 '18 at 13:21
  • 1
    Unfortunately, our software relies on a flash plugin. It doesn't work with Firefox 60, but does with 58.2. – Jack BeNimble Oct 1 '18 at 17:59
0

If you pass all dependencies to a rpm -U (or yum install) command -- not just the firefox RPM -- it should satisfy the requirements for nspr, etc. for other packages on the system. This will not work, however, if other packages depend on a specific version of nspr.

cd /path/to/downloaded/rpms
yum install *.rpm
0

What about downloading and running firefox binary without installing to system?

https://ftp.mozilla.org/pub/firefox/releases/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.