Answered Closed

OK, here's the situation::

I am using Kali Linux (Debian 32-bit (Gnome 3.28.2)) on a vbox VM. I'm also using Linux Mint 19 on another vbox VM.

I tried using lshw command in the Kali Linux terminal, but it pretty much told me "haha you idiot FAIL." So, then I knew I'd have to install it. But before that, I knew I should probably search the available packages first.

When I use the following code to search for lshw:

sudo apt-cache search lshw


sudo apt-cache search lshw-gtk

Mint 19 found the lshw and lshw-gtk packages just fine, however, Kali didn't find anything. Both of them found apache2 just fine.

I tried to install lshw despite the search finding nothing by using

apt-get install lshw

But that told me

E: Unable to locate package lshw

I didn't need to install lshw on Mint 19, because when I tested it to see if it was pre-installed it worked fine. It's wasn't pre-installed on Kali though.

Now, I don't know what to do to get lshw installed on my Debian Kali Linux.

  • You could just try copying the usr/bin/lshw binary over from Mint. It doesn't seem to have any tricky dependencies. – mosvy Oct 1 '18 at 1:11
  • 1
    you should not call Kali Linux : Debian Kali Linux, using deb or debiand repo as the main packages in the OS doesn't make your distribution a Debian. please provide the content of your /etc/apt/sources.list it seems your Kali install is no longer correct. You should also provide the output of apt update and apt upgrade – Kiwy Oct 1 '18 at 14:57

Looks like you may need to install it manually. Here's the lshw github page: https://github.com/lyonel/lshw

| improve this answer | |
  • This method worked, not not for making or installing the GUI. But I won't complain because I have working cmd lshw. – Ziana Mitchell Oct 1 '18 at 11:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.