2

I've just installed Debian Stretch 9.5. I've a dual boot (Debian + Windows) and the grub menu worked properly. Since I mainly use Debian I disabled grub menu in order to speed up the boot process (edit of the /etc/default/grub file) and it still works properly.

I wonder if there is a way to open the grub menu at boot time the few times I need to access Windows, having the grub menu disabled.

I found several posts where they suggested to press and hold Shift button during the boot, but it doesnt't work for me. Have you any suggestion? Thanks!

2

Holding down shift apparently only works in UEFI mode, so check if that's enabled.

Why not just put a timeout of 1 second for the grub menu. That'll only add 1 second to boot time, but will mean that you can change very easily (pressing any key cancels the timeout).

As root, edit /etc/default/grub, set GRUB_TIMEOUT=1, and run update-grub.

  • 1
    I tried with UEFI mode but nothing. The solution adpoted is the GRUB_TIMEOUT = 1, thanks @Cyclic3 – Federico Viotti Oct 27 '18 at 9:58
  • @Frederico If it helped, could you mark it as an answer? – Cyclic3 Oct 27 '18 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.