I have PulseAudio streaming over my local Ethernet LAN. I play sound from my client (a laptop) to a PulseAudio "server" which is connected to speakers. Both run PulseAudio verion 12.2.

When I switch the client from a wired connection to WiFi on my LAN, the remote sink disappears from the drop down list of sinks available. I do not find any error messages, but I can no longer play sound over the network. Local playback still works on the client.

My PulseAudio client and server both run Arch Linux.

Here are my settings:

client and server both

Installed this package and enabled avahi-daemon:

pacman -S pulseaudio-zeroconf 
systemctl enable avahi-daemon.service
systemctl start avahi-daemon.service

server settings

/etc/pulse/default.pa and add these lines:

load-module module-native-protocol-tcp auth-ip-acl=;
load-module module-zeroconf-publish

client settings

/etc/pulse/default.pa and add these lines:

load-module module-native-protocol-tcp
load-module module-zeroconf-discover

I copied ~/.config/pulse/cookie to all devices

It does not seem to be an authorization issue because if I open paprefs in a terminal and check allow anonymous clients, it does not resolve the issue.

The client IP address when connected via wired cable is On WiFi it is

It works exactly as expected when the client is connected via wired cable, but it does not work when the client on WiFi. The server (the computer connected directly to the speakers) is always wired.

I do not know where to look next for information about resolving this.

1 Answer 1


When switching from one network interface to another, it is necessary for me to run this command:

sudo systemctl restart avahi-daemon.service

That resolves my issue. (However, I'm not sure if this is a bug or feature. I would prefer the avahi-daemon.service to automatically join mDNS multicast group on new interface.)

UPDATE: I have found that I have to run the same restart command after some period of inactivity; this may be related to power management of networking components.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .