-1

I am trying to dual boot Kali Linux and Windows 10. I did the installation watching many online guides. The differences between what I did and these guides are as follows:

1) Non-free firmware files are not available, so I just skipped it.The file names were:

ath10k/pre-cal-pci-0000:02:00.0.bin 
ath10k/cal-pci-0000:02:00.0.bin 

2) Partitioning was done by a guided largest free space.

3) Network mirroring changed to "no" and cause grub boot loader was not being installed otherwise.

After the installation grub boot menu appears, but when I select kali, the following screen shows and stuck there without any progress. What should I do next?

enter image description here

  • You either need to edit the GRUB boot entry, or the installation was not successful. – Yousef Al-Hadhrami Sep 29 '18 at 20:37
  • Post GRUB boot log so that the answer gets more readable which will help in getting an answer fast. use a live Ubuntu or any other OS to access your hard disk and copy the log using these commands # cd /boot/grub2/locale # ln -s en@quot.mo en.mo – Yousef Al-Hadhrami Sep 29 '18 at 20:39
1

Superblock last mount time is in the future.

It seems that you have Multiple Boot Systems Time Conflicts,

Operating systems store and retrieve the time in the hardware clock located on your motherboard so that it can keep track of the time even when the system does not have power. So your Windows seem to use Coordinated Universal Time(UTC) and Kali uses Local Time

Since Windows is working, your best option will be to make your Windows timing similar to Kali's, so

  1. Boot windows
  2. Hold down the Win + R. There, type regedit. Click OK and if you're using Vista or newer, acknowledge the UAC warning.
  3. Search for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
  4. Set the value to 0
  5. Your time is now Local Time in both OS's

If Windows is using Local Time and you want it to use UTC then:

  1. Boot windows
  2. Hold down the Win + R. There, type regedit.
  3. Navigate to the key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation.
  4. Create new DWORD (32-bit) Value or QWORD (64-bit) value according to your operating system, name it RealTimeIsUniversal.

  5. Set its value to 1.

You can then later stick to Local Time or change it to UTC in both OS's after you boot Kali

  • I do not have a file or folder named RealTimeIsUniversal. I would like to show the screenshot but i do not know how to attach a screenshot in the comment – Sasindu Dharmawardhana Sep 29 '18 at 21:50
  • try searching for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation – Yousef Al-Hadhrami Sep 29 '18 at 21:55
  • It comes up with some files but doesn't have the RealTimeIsUniversal file. – Sasindu Dharmawardhana Sep 29 '18 at 22:08
  • I think then it's the opposite, your Kali uses UTC, and your windows uses Local Time, I've updated the answer to do the opposite – Yousef Al-Hadhrami Sep 29 '18 at 22:13
  • 1
    It comes up with some files but doesn't have the RealTimeIsUniversal file ..... RealTimeIsUniversal is not a file and it is not a directory .... it is a windows registry key – jsotola Oct 1 '18 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.