5

I have KDE as the window manager, and I cannot figure out how to stop it making ding-a-ling noises at extreme volume. Example:

  1. Open Konsole.
  2. Open a second tab.
  3. Close the whole window with its × button.
  4. A message box interrogates me, asking if I really want to close both tabs. The message box resets the system volume from where I need it for my headphones, ~10%, to 100%, and then emits a pointless ding-a-ling noise. It's horrifyingly loud. I jump every time.

I haven't done anything weird with the sound settings to cause this. Linux has behaved this way since I set it up a month ago.

Question: Where is the checkbox to turn off KDE's noises? It was easy to turn off the sound theme when I used Windows, but I feel like I've looked all over KDE and never found the setting. Currently I live in fear of clicking things that I know will make the noise.

System: Debian Stretch 9.5
KDE: Plasma 5.8.6

3
  • 1
    I live in fear of clicking things .... has it occurred to you to remove your headphones until you figure out how to turn down the volume?
    – jsotola
    Oct 1, 2018 at 6:35
  • 1
    you are using the wrong term .... searching the internet for noises will not give you any answers ..... search instead for kde system sounds and you will find an answer
    – jsotola
    Oct 1, 2018 at 19:01
  • @jsotola I did try.
    – Boann
    Oct 3, 2018 at 4:05

2 Answers 2

4

Open System Settings and click on Notifications: System settings

In the Notifications window, first select the event source for which you want to configure notification, in this example, I chose Plasma Workspace. In the table, the first column reflects the state of an event. When a sound has been configured, a little play button is displayed. If you want to disable the sound for a certain event, click on the event and deselect the Play a sound checkbox. You can quickly disable all sounds for a certain event source by clicking the button Disable sounds for all of these events.

Notifications

If you want to disable all notification sounds, you have to select each event source and click the "disable all" button. AFAIK, it's not possible to disable all sounds with one click.

However, it is possible to mute them. If you go again in System Settings -> Multimedia -> Audio Volume, you can simply mute all notification sounds: Mute notification volume

2
  • 2
    I couldn't find "Plasma Workspace" as an "event source" in my version of KDE. I was going to say so, until I accidentally scroll-wheeled onto more event sources! Originally I only ever found the first ten, because the scroll bar for that list is way over on the other side of the screen, so I never noticed it. After disabling all sounds in all event sources as you suggest, yes, finally KDE shuts up! Thank you! By the way I'd already been to Multimedia -> Audio Volume, and already set Notification Sounds to 0%, and muted it, and that setting seems to have absolutely no effect. Never mind!
    – Boann
    Oct 3, 2018 at 3:23
  • glad i could help, enjoy the silence ;) muting works too in my case, but I guess that's some whole other problem (pulseaudio releated i guess)
    – mx1up
    Oct 3, 2018 at 10:13
2

Open /etc/pulse/daemon.conf as admin and set flat-volumes = no. Then restart pulseaudio with pulseaudio -k or logout and login. After that, system sounds should not max audio any longer.

PulseAudio, which is default for debian and a few friends, some 3-4 years ago made the decision to activate flat-volumes by default, which is stupid at best, downright assault at worst, and dangerous in any case.

I have to do a lot of work with fairly strong headphones. Therefore I often have the volume to 5% if I run music, as thats loud enough. Thanks to PulseAudio maxing the volume, now I (25yo) have Tinitus (permanently ringing ears).

4
  • 1
    What are flat volumes? What does this setting do?
    – Boann
    Sep 15, 2019 at 17:32
  • 1
    @Boann sorry for the late answer. Basically flat-volume tells the system to play its sound on one preset volume level, ... wich happens to be hardcoded to maximized volume. Thereby it ensures that you will hear a system-notification. Sadly it also ensures permanent hearing damage if you do anything where you need the volume low, as it just maximizes the volume, instead of playing just systemsound on that level..
    – Teck-freak
    Nov 6, 2019 at 15:12
  • Who's the jackass who thought system notification sounds were so important? As if I can't already see the huge pop-up in the middle of the screen... May 22, 2020 at 2:06
  • @Drew I've got no idea. But I wholehartedly agree with you. In my eyes it is assault. In my country it's a punishable offense, roughly translating to "physical harm by strong neglect". --- Dont get me wrong: I understand a need for having notification sounds be heard even if the rest is quiet/inaudible. But that should be ACTIVELY set in the system settings, set to a custom chosen level, and MUST NOT EVER be preset to active and ESPECIALLY NOT TO MAXIMUM! And hiding it in a non-explanatory variable name is ... at least stupid, if not (criminal) intent.
    – Teck-freak
    May 31, 2020 at 13:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .