2

Posted in order to give the answer (QnA).


I have installed Lxqt desktop on top of Kubuntu 18.04. That means I can still use the krunner launcher of KDE/Plasma if I chose to, but Lxqt has its own launcher called "runner" (lxqt-runner) that is similar and very light.

enter image description here

It is supposed to be used with Alt-F1. That can be changed in the Shortcut Key settings but not to just the Super-key.

Is it possible to make this launcher run with only the Super key?

2

LXQt 0.12:

Install the ksuperkey program as indicated here.

Just running ksuperkey would asign the Super key to the program that was already set to run with the shortcut Alt-F1. The latter can be changed (see the link or the readme file), but in the present case we don't need to do that, only be sure that Alt-F1t is precisely the shortcut of the lxqt-runner under Shortcut Keys settings:

enter image description here

Then add ksuperkey at the list of startup programs under Session Settings/Autostart:

enter image description here


LXQt 0.13:

The Super key (Super_L) can be assigned as such from Shortcut Keys settings.

enter image description here

  • Hint: Press Alt-F1 to see the main menu, then type in "Shortcut" to see the application "Shortcut Keys". After you launch it, find the first entry that says "Show/hide runner dialog" (it's already there and it's bound to the keystroke Alt-F2. What you want to do is edit it and change it to the Super key. – 010110110101 Mar 6 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy