0

I've installed a minimal installation of CentOS 7, meaning no GUI, on my Dell XPS 15 9560 laptop.  uname -r returns 3.10.0-862.11.6.el7.x86_64.  The laptop does not have an Ethernet card, but it does have a Wi-Fi card.  During the installation I configured a Wi-Fi connection and I could confirm that I received an IP address.

When booting into the OS, however, I don't have an active connection. I've tried to find out how to activate the Wi-Fi and establish a connection with the tools already installed (as I can't install any new ones), but to no avail.

I'm not sure exactly what is of interest but this is what I know:

  • ip addr shows that the interface (is that the correct term?) wls2s0 is DOWN.
  • running nmtui (after systemctl enable NetworkManager and service NetworkManager start) shows the connection I created and it seems correct. After all I successfully connected during the installation. The "activate a connection" menu is empty, though.
  • nmcli d shows a row like so: wlp2s0 wifi unmanaged --
  • nmcli connection show lists my connection but the "device"-field is empty (--).
  • nmcli connection up <connection name> gives me the following error: Error: Connection activation failed: No suitable device found for this connection.

I suspect my Wi-Fi card is not active, but I'm not sure how to activate it. I've tried the Fn+PrtScr combination, which usually activates it, but no luck.

Running lshw gave me some additional info. The Wi-Fi card is listed under pci devices as:

 *-network DISABLED
    description: Wireless interface
    product: QCA6174 802.11ac Wireless Network Adapter
    vendor: Qualcomm Atheros
    ...
    logical name: wlp2s0
    ...
    configuration: broadcast=yes driver=ath10k_pci driverversion=3.10.0-862.11.6.el7.x86_64 firmware=WLAN.RM.4.4.1-00051-QCARMSWP-1 latency=0 link=no multicast=yes wireless=IEEE 802.11 resources:  irq:140 memory:ed200000-ed3fffff

so the driver seems to be ath10k_pci.  Running lsmod | grep "ath10k" gives me the following:

ath10k_pci    47418   0
ath10k_core   325711  1  ath10k_pci
ath            29446  1  ath10k_core
mac80211      714741  1  ath10k_core
cfg80211      623433  3  ath,mac88211,ath10k_core

I'm not sure if the above means that the ath10k_pci driver is being loaded, though.

Neither lsusb nor lspci is present on the system.

Any suggestions, where do I go from here?

  • Once you find out which driver (if any) is used for your hardware you could use lsmod to see if it is being loaded into the kernel. If it is not automatically loaded you can use modprobe to test it out. – Jeff H. Sep 27 '18 at 22:33
  • @roaima Neither lsusb or lspci are present on the system, but I could use lshw to get some info. I've added it to the question. – Christian Eriksson Sep 27 '18 at 22:48
  • @JeffH. I'm not sure exactly how to interpret the output of lsmod but I do find some lines referring to ath10k_pci which seems to be the driver, I'm not sure if it means that it's being loaded though. I've added the output to the question. – Christian Eriksson Sep 27 '18 at 22:56
  • @roaima uname -r returns 3.10.0-862.11.6.el7.x86_64 – Christian Eriksson Sep 27 '18 at 23:08
  • Your device isn't listed under supported devices for the ath10k driver wireless.wiki.kernel.org/en/users/drivers/… Furthermore it looks like kernel 4.0 adds support for your specific device wireless.wiki.kernel.org/en/users/drivers/ath10k/… – Jeff H. Sep 27 '18 at 23:17
1

See https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1520343 for instructions on the Ubuntu approach to fixing the issue. Here are what I think are the relevant extracts, but note that I have not tested this as I don't have your hardware:

If you have kernel 4.5.0

sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/
sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

Reboot or reload the ath10k_pci module and you should be able to connect.

Otherwise

sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/
sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/board-2.bin?raw=true
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true
sudo chmod +x /lib/firmware/ath10k/QCA6174/hw3.0/*

Reboot or reload the ath10k_pci module and you should be able to connect.

Caveats

A number of comments on the original link say that these fixes do not work straight off, and tweaks are supplied. I would strongly recommend you work your way through the entire thread. Read it twice - once to see what's going on, and the once (at least) to work out what needs applying in your situation. This isn't going to be easy.

  • Thank you, I'll have to come back to this with a fresh set of eyes tomorrow. But at first glance, if I understand this correctly I'll have to find a usb-ethernet card to be able to use wget and I interpret the output from uname -r that I have a kernel version lower than 4.5.0, correct? – Christian Eriksson Sep 27 '18 at 23:21
  • @ChristianEriksson you can download the software elsewhere and bring it across by usb stick. You have an older kernel so the second set of instructions should work for you. – roaima Sep 28 '18 at 7:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.