0

I'm using kickstart's booloader options to suppress the consistent device naming feature for network interfaces on Centos 7.5. A minimal example of my kickstart file is as below:

auth --enableshadow --passalgo=sha512
cdrom
text
keyboard --vckeymap=us --xlayouts='us'
lang en_US.UTF-8
bootloader --location=mbr --append="net.ifnames=0 biosdevname=0"

During the installation, I see that my VM (running on vSphere 6.0) is named ens192. After the install, it gets renamed to eth0. However, the script containing networking configuration is still named after the original interface /etc/sysconfig/network-scripts/ifcfg-ens192

I see some posts on stackexchange (e.g this) and elsewhere where one or both of the options net.ifnames=0/ biosdevname=0 should fix this but it does not work for me.

I have two questions:

  1. How do I know that the options passed to bootloader were honored? They do not appear in /proc/cmdline. Is there any other place where these are recorded
  2. How do I successfully disable consistent device naming?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.