1

In most flavors of Linux that I've used, the output for apt search does not include the current state display but in Linux Mint (Sylvia) it is displaying and I would like to remove it because it interferes with my string-beginning (^) grep filters.

When I use the formatting flag (-F) I can get it to work just fine.

apt search -F "%p" apache

I would prefer this to be the default behavior. I have tried adding the configuration to the .aptitude/config file but am seeing no change. I tried both with Aptitude capitalized and all lowercase, as the configurations in the file by default have it lowercase, but the documentation has it capitalized.

Aptitude::UI::Package-Display-Format "%p";

I'm not sure if it's relevant, but when I add the display format to .aptitude/config it's inserting the following line above it every time, and if I delete the line it is replaced the next time I open the file.

aptitude::UI "";

I'm using apt 1.2.27 and aptitude 0.7.4-2ubuntu2.

Aptitude references
https://www.debian.org/doc/manuals/aptitude/ch02s05s05.en.html#configPackage-Display-Format https://www.debian.org/doc/manuals/aptitude/ch02s05s01.en.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.