0

I'm running LiClipse (a version of Eclipse IDE targeted at Python development) on a remote CentOS 7 host with X11 forwarding to xming on Windows 10.

The application starts up fine, but the fonts are incredibly small, and the wrong type (the default is 'sans', but the displayed font is different). Changing the font type and size in the application preferences has no effect.

enter image description here

Is it possible that I'm missing some font package in CentOS or Xming (I have installed xming-fonts 7.7.0.10)? How can this be solved?

EDIT: xset q shows the following font paths (I switched between xming and VcXsrv and the results are the same, I have now stuck to VcXsrv)

Font Path:
    C:\apps\VcXsrv\fonts/misc/,C:\apps\VcXsrv\fonts/TTF/,C:\apps\VcXsrv\fonts/OTF,C:\apps\VcXsrv\fonts/Type1/,C:\apps\VcXsrv\fonts/100dpi/,C:\apps\VcXsrv\fonts/75dpi/,C:\apps\VcXsrv\fonts/cyrillic/,C:\apps\VcXsrv\fonts/Speedo/,C:\apps\VcXsrv\fonts/terminus-font/,built-ins

I have successfully changed the text editor font in the application, by picking the Courier 10 Pitch font in the appearance settings menu. The problem is that none of the default-selected fonts, like Monospace or Sans render properly.

I suspected the missing fonts might be in the C:\Windows\Fonts folder, so I tried added it to the font-dirs file, and the -fp command-line argument of both xming and VcXsrv with no success. That folder is simply ignored, it does not show in the output of xset q even if it's the only option provided, which is now an even bigger mystery.

So it seems the issue is that there's a mismatch between what fonts LiClipse/X11 is expecting to use and what Xming/VcXsrv are providing.

EDIT 2: Not a duplicate of How to configure fonts on a remote X connection (XDMCP vs. ssh)? The solution to that question does not solve this one, and software in use is different.

  • 1
    Xming should have a -dpi option. (At least similar VcXsrv does have it). Try to run Xming with e.g. -dpi 120. – mviereck Sep 26 '18 at 13:41
  • Setting the -dpi option in the xming startup parameters solved the font sizing issue, but not the wrong font type. – André Fernandes Sep 26 '18 at 18:00
  • Good! Then I assume you are missing a CentOS font package now. Though, I am not sure. Side note: Write e.g. @mviereck so I receive a notification. I've looked for myself here again, otherwise I would not have seen your comment. – mviereck Sep 27 '18 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.