1

I am running a new instance of CentOS 7 w/ Gnome desktop. I want to get Wine running on my instance of CentOS 7 so that I can run KeePass.

I got Wine installed via EPEL, but running any .exe from wine results in:

000f:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"WineBus" failed to start: 2
wine: Bad EXE format for <name of any executable I try>

I have uninstalled this version of Wine. Upon searching for "installing WINE on CentOS7", I ran across these blogs:

Both get me to the same sticking point during compliation. I run ./configure inside the wine source folder without a problem. I run the make command, and the project begins to compile. However, it always hangs on the dlls/cabinet/tests portion of compilation. The specific error is:

winegcc: File does not exist: fdi.o
make[1]: *** [cabinet_test-stripped.exe.so] Error 2
make[1]: Leaving directory `/tmp/wine-3.15/dlls/cabinet/tests'
make: *** [dlls/cabinet/tests] Error 2

I have tried compiling Wine 2.0.2, 3.0, 3.0.3, 3.15, & 3.16. ALL compilations have failed on the exact same file. I have confirmed that the 'missing' fdi.o is present.

[myname@mymachine wine-3.15]$ ls ./dlls/cabinet/tests/
total 240
-rw-rw-r--. 1 myname myname    76 Aug 31 15:24 Makefile.in
-rw-rw-r--. 1 myname myname 31307 Aug 31 15:24 fdi.c
...
-rw-rw-r--. 1 myname myname 55940 Sep 25 14:16 fdi.o
...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.