0

I'm trying to mount my Synology NAS to Ubuntu with fstab, and I have some folders on the NAS containing '!' in the folder name, as well as spaces. The spaces I found out that I can escape with \040, but what about the ! (exclamation mark)? I've searched but haven't found any answer yet.

This is a part of my fstab filer right now;

192.168.1.102:/volume1/Disk2/!Film\040-\040480p nfs auto 0 0
192.168.1.102:/volume1/Disk2/!Film\040-\040720p nfs auto 0 0
192.168.1.102:/volume1/Disk2/!Film\040-\0401080p nfs auto 0 0
192.168.1.102:/volume1/Disk2/!Film\040-\040Barn nfs auto 0 0
192.168.1.102:/volume1/Disk2/!Film\040-\040Barn\040-\040Temp nfs auto 0 0
192.168.1.102:/volume1/Disk2/!Film\040-\040Barn\040-\040Disneynfs auto 0 0
  • 1
    Welcome to U&L! What methods of escaping have you tried so far? \!? \041? – JigglyNaga Sep 25 '18 at 11:31
  • tried \!, not working. Haven't tried \041 because I couldn't find any list that explained all substitutions for special characters. But thanx, I'll try that. – b0red Sep 25 '18 at 11:39
0

I should add \041 and put the path as well, this worked:

 192.168.1.102:/volume1/Disk2/!Film\040-\040480p /media/movies 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.